summaryrefslogtreecommitdiff
path: root/sys-devel/gdb-apple/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
commit7860ad41012a3808c645607818b64ad7dab025e9 (patch)
tree102565176c19f5aef57ae4f6faecd3bded6f36ee /sys-devel/gdb-apple/files
parentb83f9f17a27e03508085814208cd9c89a07f1f49 (diff)
gentoo auto-resync : 13:01:2024 - 13:10:51
Diffstat (limited to 'sys-devel/gdb-apple/files')
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch87
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch128
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-1705-darwin8-10.patch11
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-768-texinfo.patch10
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-no-global-gdbinit.patch23
5 files changed, 0 insertions, 259 deletions
diff --git a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch
deleted file mode 100644
index a05169cec25d..000000000000
--- a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8-9.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- src/gdb/macosx/macosx-nat-dyld.c
-+++ src/gdb/macosx/macosx-nat-dyld.c
-@@ -2083,7 +2083,9 @@
- case MH_DYLIB:
- case MH_DYLINKER:
- case MH_BUNDLE:
-+#ifdef MH_KEXT_BUNDLE
- case MH_KEXT_BUNDLE:
-+#endif
- break;
- case MH_FVMLIB:
- case MH_PRELOAD:
-@@ -2412,7 +2414,9 @@
- break;
- case MH_DYLINKER:
- case MH_BUNDLE:
-+#ifdef MH_KEXT_BUNDLE
- case MH_KEXT_BUNDLE:
-+#endif
- entry->reason = dyld_reason_dyld;
- break;
- default:
---- src/gdb/macosx/macosx-nat-dyld-process.c
-+++ src/gdb/macosx/macosx-nat-dyld-process.c
-@@ -407,7 +407,9 @@
- case MH_DYLIB:
- break;
- case MH_BUNDLE:
-+#ifdef MH_KEXT_BUNDLE
- case MH_KEXT_BUNDLE:
-+#endif
- break;
- default:
- return;
- return;
---- src/gdb/macosx/macosx-nat-inferior.c
-+++ src/gdb/macosx/macosx-nat-inferior.c
-@@ -2692,6 +2692,7 @@
- if (tp->private == NULL || tp->private->app_thread_port == 0)
- return NULL;
-
-+#ifdef THREAD_IDENTIFIER_INFO_COUNT
- thread_identifier_info_data_t tident;
- unsigned int info_count;
- kern_return_t kret;
-@@ -2719,6 +2720,7 @@
- }
- }
- }
-+#endif
- return buf;
- }
-
---- src/gdb/macosx/macosx-nat-infthread.c
-+++ src/gdb/macosx/macosx-nat-infthread.c
-@@ -809,6 +809,7 @@
- print_stack_frame (get_selected_frame (NULL), 0, LOCATION);
- switch_to_thread (current_ptid);
-
-+#ifdef THREAD_IDENTIFIER_INFO_COUNT
- thread_identifier_info_data_t tident;
- info_count = THREAD_IDENTIFIER_INFO_COUNT;
- kret = thread_info (tid, THREAD_IDENTIFIER_INFO, (thread_info_t) &tident,
-@@ -878,6 +879,7 @@
- printf_filtered ("\tcurrent priority: %d\n", pth.pth_priority);
- printf_filtered ("\tmax priority: %d\n", pth.pth_maxpriority);
- }
-+#endif
-
- printf_filtered ("\tsuspend count: %d", info.suspend_count);
-
-@@ -1175,6 +1177,7 @@
- ui_out_field_fmt (uiout, "mach-port-number", "0x%s",
- paddr_nz (app_thread_name));
-
-+#ifdef THREAD_IDENTIFIER_INFO_COUNT
- thread_identifier_info_data_t tident;
- info_count = THREAD_IDENTIFIER_INFO_COUNT;
- kret = thread_info (tid, THREAD_IDENTIFIER_INFO, (thread_info_t) &tident,
-@@ -1207,6 +1210,7 @@
- paddr_nz (struct_addr));
- }
- }
-+#endif
- }
-
-
diff --git a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch b/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch
deleted file mode 100644
index f8ecc30be7f6..000000000000
--- a/sys-devel/gdb-apple/files/gdb-apple-1518-darwin8.patch
+++ /dev/null
@@ -1,128 +0,0 @@
---- src/gdb/macosx/macosx-nat-inferior.c
-+++ src/gdb/macosx/macosx-nat-inferior.c
-@@ -60,13 +60,17 @@
- #include <sys/sysctl.h>
- #include <sys/proc.h>
- #include <mach/mach_error.h>
-+#if defined(TARGET_ARM)
- #include <spawn.h>
-+#endif
-
- #include <semaphore.h>
-
- #include <dlfcn.h>
-+#if 0
- #include <libproc.h>
- #include <sys/proc_info.h>
-+#endif
-
- #include "macosx-nat-dyld.h"
- #include "macosx-nat-inferior.h"
---- src/gdb/macosx/macosx-nat-info.c
-+++ src/gdb/macosx/macosx-nat-info.c
-@@ -45,6 +45,22 @@
- #include "macosx-nat-inferior.h"
- #include "macosx-nat-inferior-debug.h"
-
-+#ifdef __ppc__
-+#ifndef __darwin_ppc_thread_state
-+#define __darwin_ppc_thread_state ppc_thread_state
-+#define __r0 r0
-+#define __srr0 srr0
-+#define __srr1 srr1
-+#define __cr cr
-+#define __xer xer
-+#define __lr lr
-+#define __ctr ctr
-+#endif
-+#ifndef __darwin_ppc_exception_state
-+#define __darwin_ppc_exception_state ppc_exception_state
-+#endif
-+#endif
-+
- extern macosx_inferior_status *macosx_status;
-
- #define CHECK_ARGS(what, args) \
---- src/gdb/macosx/macosx-nat-infthread.c
-+++ src/gdb/macosx/macosx-nat-infthread.c
-@@ -36,8 +36,10 @@
- #include <sys/dir.h>
- #include <inttypes.h>
-
-+#if 0
- #include <libproc.h>
- #include <sys/proc_info.h>
-+#endif
-
- #include "macosx-nat-inferior.h"
- #include "macosx-nat-inferior-util.h"
---- src/gdb/macosx/macosx-tdep.c
-+++ src/gdb/macosx/macosx-tdep.c
-@@ -64,7 +64,6 @@
- #include "gdbcore.h"
-
- #include <dirent.h>
--#include <libgen.h>
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <sys/param.h>
---- src/gdb/remote.c
-+++ src/gdb/remote.c
-@@ -63,7 +63,6 @@
- #include "macosx-nat-dyld.h"
- #include "macosx-nat-dyld-process.h"
- #endif
--#include <execinfo.h>
-
- /* Prototypes for local functions. */
- static void cleanup_sigint_signal_handler (void *dummy);
-@@ -475,11 +474,13 @@
- static void
- remote_backtrace_self (const char *message)
- {
-+#if 0
- void *bt_buffer[100];
- int count = backtrace (bt_buffer, 100);
- if (message && message[0])
- fprintf_filtered (gdb_stderr, "%s", message);
- backtrace_symbols_fd (bt_buffer, count, STDERR_FILENO);
-+#endif
- }
-
- static void
---- src/gdb/symfile.c
-+++ src/gdb/symfile.c
-@@ -67,7 +67,6 @@
- #include <ctype.h>
- #include <time.h>
- #include <sys/time.h>
--#include <libgen.h>
-
- #include <sys/mman.h>
-
---- src/gdb/utils.c
-+++ src/gdb/utils.c
-@@ -28,7 +28,6 @@
- #include "event-top.h"
- #include "exceptions.h"
- #include "bfd.h"
--#include <execinfo.h>
- #include <sys/resource.h>
- #include <uuid/uuid.h>
-
-@@ -879,6 +878,7 @@
- target_terminal_ours ();
- begin_line ();
-
-+#if 0
- /* APPLE LOCAL: Do a stack crawl of how we got here so we're more likely
- to get useful bug reports. */
- {
-@@ -887,6 +887,7 @@
- fprintf (stderr, "gdb stack crawl at point of internal error:\n");
- backtrace_symbols_fd (bt_buffer, count, STDERR_FILENO);
- }
-+#endif
-
- /* Create a string containing the full error/warning message. Need
- to call query with this full string, as otherwize the reason
diff --git a/sys-devel/gdb-apple/files/gdb-apple-1705-darwin8-10.patch b/sys-devel/gdb-apple/files/gdb-apple-1705-darwin8-10.patch
deleted file mode 100644
index 32247431fe89..000000000000
--- a/sys-devel/gdb-apple/files/gdb-apple-1705-darwin8-10.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gdb/macosx/macosx-nat-dyld.c
-+++ src/gdb/macosx/macosx-nat-dyld.c
-@@ -788,7 +788,7 @@
- }
- else
- {
--#if defined (NM_NEXTSTEP)
-+#if defined (NM_NEXTSTEP) && defined(TASK_DYLD_INFO_COUNT)
- if (macosx_status->task == TASK_NULL)
- return 0;
-
diff --git a/sys-devel/gdb-apple/files/gdb-apple-768-texinfo.patch b/sys-devel/gdb-apple/files/gdb-apple-768-texinfo.patch
deleted file mode 100644
index 41153d8436de..000000000000
--- a/sys-devel/gdb-apple/files/gdb-apple-768-texinfo.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/Makefile.in
-+++ src/Makefile.in
-@@ -280,6 +280,6 @@
- then echo $$r/$(BUILD_SUBDIR)/texinfo/makeinfo/makeinfo ; \
- else if (${CONFIGURED_MAKEINFO} --version \
-- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[2-9]|[5-9])') >/dev/null 2>&1; \
-+ | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[2-9]|4\.[1-9][0-9]|[5-9])') >/dev/null 2>&1; \
- then echo ${CONFIGURED_MAKEINFO}; else echo $$s/missing makeinfo; fi; fi`
-
- # This just becomes part of the MAKEINFO definition passed down to
diff --git a/sys-devel/gdb-apple/files/gdb-apple-no-global-gdbinit.patch b/sys-devel/gdb-apple/files/gdb-apple-no-global-gdbinit.patch
deleted file mode 100644
index 0c132ec5b384..000000000000
--- a/sys-devel/gdb-apple/files/gdb-apple-no-global-gdbinit.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Sourcing /etc/gdb.conf is annoying mainly because Apple put
- set history save on
-in there, which means everywhere you run it, you end up with a
-.gdb_history file.
-
---- src/gdb/main.c
-+++ src/gdb/main.c
-@@ -675,6 +675,7 @@
- memset (&cwdbuf, 0, sizeof (struct stat));
- /* APPLE LOCAL end move inits up */
- /* APPLE LOCAL begin global gdbinit */
-+#ifdef WANT_GLOBAL_GDBINIT
- memset (&globalbuf, 0, sizeof (struct stat));
- stat (gdbinit_global, &globalbuf);
- if (!inhibit_gdbinit)
-@@ -683,6 +684,7 @@
- source_file (gdbinit_global, 0);
- }
- do_cleanups (ALL_CLEANUPS);
-+#endif
- /* APPLE LOCAL end global gdbinit */
-
- /* APPLE LOCAL: Set the $_Xcode convenience variable at '0' before sourcing