summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-9.4.1_pre9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /sys-devel/gcc/gcc-9.4.1_pre9999.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'sys-devel/gcc/gcc-9.4.1_pre9999.ebuild')
-rw-r--r--sys-devel/gcc/gcc-9.4.1_pre9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-9.4.1_pre9999.ebuild b/sys-devel/gcc/gcc-9.4.1_pre9999.ebuild
new file mode 100644
index 000000000000..8c31f450a34c
--- /dev/null
+++ b/sys-devel/gcc/gcc-9.4.1_pre9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_GCC_VER="9.4.0"
+PATCH_VER="1"
+
+inherit toolchain
+
+# Don't keyword live ebuilds
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
+ toolchain_src_prepare
+}