summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-4.8.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
commitccf84bcd604130256d1377cd58f0a634ae6ee20f (patch)
treef42a709e0c7805183f5680883bc76dc935b7a0cc /sys-devel/gcc/gcc-4.8.5-r1.ebuild
parentc85a90f90521c7e11d618b527d6630cc64cecbd4 (diff)
gentoo resync : 28.12.2017
Diffstat (limited to 'sys-devel/gcc/gcc-4.8.5-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.8.5-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.8.5-r1.ebuild b/sys-devel/gcc/gcc-4.8.5-r1.ebuild
new file mode 100644
index 000000000000..547dea86f3a1
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.8.5-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.3"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.6.2"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
+#end Hardened stuff
+
+inherit eutils toolchain
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ toolchain_src_prepare
+
+ use vanilla && return 0
+ #Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
+}