summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-14.1.1_p20240511.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
commit236e75597883501f8700d9ba1a5c8276f578a17f (patch)
tree6b441a1dfa3a82840e3aa74678cc90c5294a4bca /sys-devel/gcc/gcc-14.1.1_p20240511.ebuild
parentbfd63d5b0e96ad32e0d0a8fe15512b6a9ac6fc9e (diff)
gentoo auto-resync : 22:05:2024 - 00:06:25HEADmaster
Diffstat (limited to 'sys-devel/gcc/gcc-14.1.1_p20240511.ebuild')
-rw-r--r--sys-devel/gcc/gcc-14.1.1_p20240511.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/sys-devel/gcc/gcc-14.1.1_p20240511.ebuild b/sys-devel/gcc/gcc-14.1.1_p20240511.ebuild
deleted file mode 100644
index 2a180604e938..000000000000
--- a/sys-devel/gcc/gcc-14.1.1_p20240511.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-TOOLCHAIN_PATCH_DEV="sam"
-PATCH_GCC_VER="14.1.0"
-PATCH_VER="1"
-MUSL_VER="1"
-MUSL_GCC_VER="14.1.0"
-PYTHON_COMPAT=( python3_{10..12} )
-
-if [[ -n ${TOOLCHAIN_GCC_RC} ]] ; then
- # Cheesy hack for RCs
- MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
- MY_P=${PN}-${MY_PV}
- GCC_TARBALL_SRC_URI="mirror://gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
- TOOLCHAIN_SET_S=no
- S="${WORKDIR}"/${MY_P}
-fi
-
-inherit toolchain
-
-if tc_is_live ; then
- # Needs to be after inherit (for now?), bug #830908
- EGIT_BRANCH=releases/gcc-$(ver_cut 1)
-elif [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
- # Don't keyword live ebuilds
- #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
- :;
-fi
-
-if [[ ${CATEGORY} != cross-* ]] ; then
- # Technically only if USE=hardened *too* right now, but no point in complicating it further.
- # If GCC is enabling CET by default, we need glibc to be built with support for it.
- # bug #830454
- RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
- DEPEND="${RDEPEND}"
- BDEPEND="amd64? ( >=${CATEGORY}/binutils-2.30[cet(-)?] )"
-fi
-
-src_prepare() {
- local p upstreamed_patches=(
- # add them here
- )
- for p in "${upstreamed_patches[@]}"; do
- rm -v "${WORKDIR}/patch/${p}" || die
- done
-
- toolchain_src_prepare
-
- eapply_user
-}