summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-12.1.1_p20220528-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-devel/gcc/gcc-12.1.1_p20220528-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-devel/gcc/gcc-12.1.1_p20220528-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-12.1.1_p20220528-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-12.1.1_p20220528-r1.ebuild b/sys-devel/gcc/gcc-12.1.1_p20220528-r1.ebuild
new file mode 100644
index 000000000000..aa68dc8eaadf
--- /dev/null
+++ b/sys-devel/gcc/gcc-12.1.1_p20220528-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+TOOLCHAIN_PATCH_DEV="sam"
+PATCH_VER="7"
+PATCH_GCC_VER="12.1.0"
+MUSL_VER="4"
+MUSL_GCC_VER="12.1.0"
+
+inherit toolchain
+
+# Don't keyword live ebuilds
+if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~loong"
+fi
+
+# Technically only if USE=hardened *too* right now, but no point in complicating it further.
+# If GCC is enabling CET by default, we need glibc to be built with support for it.
+# bug #830454
+RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
+DEPEND="${RDEPEND}"
+BDEPEND=">=${CATEGORY}/binutils-2.30[cet(-)?]"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ eapply_user
+}