summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-12.0.0_pre9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /sys-devel/gcc/gcc-12.0.0_pre9999.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'sys-devel/gcc/gcc-12.0.0_pre9999.ebuild')
-rw-r--r--sys-devel/gcc/gcc-12.0.0_pre9999.ebuild32
1 files changed, 25 insertions, 7 deletions
diff --git a/sys-devel/gcc/gcc-12.0.0_pre9999.ebuild b/sys-devel/gcc/gcc-12.0.0_pre9999.ebuild
index e8889dee6ccd..3571c4605330 100644
--- a/sys-devel/gcc/gcc-12.0.0_pre9999.ebuild
+++ b/sys-devel/gcc/gcc-12.0.0_pre9999.ebuild
@@ -1,17 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=7
-PATCH_GCC_VER="12.0.0"
-PATCH_VER="2"
+PATCH_VER="3"
+PATCH_GCC_VER="11.3.0"
+MUSL_VER="1"
+MUSL_GCC_VER="11.2.0"
+EGIT_BRANCH=master
inherit toolchain
# Don't keyword live ebuilds
#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
-EGIT_BRANCH=master
+# Technically only if USE=hardened *too* right now, but no point in complicating it further.
+# If GCC is enabling CET by default, we need glibc to be built with support for it.
+# bug #830454
+RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
+DEPEND="${RDEPEND}"
+BDEPEND="${CATEGORY}/binutils[cet(-)?]"
+
+src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
+ toolchain_src_prepare
-RDEPEND=""
-BDEPEND="${CATEGORY}/binutils"
+ eapply_user
+}