summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-11.4.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-22 00:41:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-22 00:41:01 +0000
commit23b767af73549eeb4dd3069e09d0f2fcb88669a8 (patch)
tree7ad731ac748d72a48ae7079bc8fb0718c554d65d /sys-devel/gcc/gcc-11.4.9999.ebuild
parent3003897133b1bcfe9a241c2708e938903879aee3 (diff)
gentoo auto-resync : 22:03:2023 - 00:41:01
Diffstat (limited to 'sys-devel/gcc/gcc-11.4.9999.ebuild')
-rw-r--r--sys-devel/gcc/gcc-11.4.9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sys-devel/gcc/gcc-11.4.9999.ebuild b/sys-devel/gcc/gcc-11.4.9999.ebuild
index de29705ca377..f693ec815844 100644
--- a/sys-devel/gcc/gcc-11.4.9999.ebuild
+++ b/sys-devel/gcc/gcc-11.4.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,12 +29,14 @@ if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
-# Technically only if USE=hardened *too* right now, but no point in complicating it further.
-# If GCC is enabling CET by default, we need glibc to be built with support for it.
-# bug #830454
-RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
-DEPEND="${RDEPEND}"
-BDEPEND=">=${CATEGORY}/binutils-2.30[cet(-)?]"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ # Technically only if USE=hardened *too* right now, but no point in complicating it further.
+ # If GCC is enabling CET by default, we need glibc to be built with support for it.
+ # bug #830454
+ RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
+ DEPEND="${RDEPEND}"
+ BDEPEND=">=${CATEGORY}/binutils-2.30[cet(-)?]"
+fi
src_prepare() {
local p upstreamed_patches=(