summaryrefslogtreecommitdiff
path: root/sys-devel/dwz/dwz-0.15-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-20 00:35:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-20 00:35:55 +0000
commit84be07a71d5002585ac714a892bbfd57f3091b4e (patch)
tree0fe24d663efe493f7c44c5dea33b63bb2364e706 /sys-devel/dwz/dwz-0.15-r1.ebuild
parent810f2cdadf662a6bfaaed425b6ecd216a301cd3d (diff)
gentoo auto-resync : 20:03:2023 - 00:35:55
Diffstat (limited to 'sys-devel/dwz/dwz-0.15-r1.ebuild')
-rw-r--r--sys-devel/dwz/dwz-0.15-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-devel/dwz/dwz-0.15-r1.ebuild b/sys-devel/dwz/dwz-0.15-r1.ebuild
new file mode 100644
index 000000000000..a34aab7c8b3f
--- /dev/null
+++ b/sys-devel/dwz/dwz-0.15-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="DWARF optimization and duplicate removal tool"
+HOMEPAGE="https://sourceware.org/dwz"
+SRC_URI="https://sourceware.org/ftp/dwz/releases/${P}.tar.xz"
+
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/elfutils
+ dev-libs/xxhash
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-libs/elfutils[utils]
+ dev-util/dejagnu
+ sys-devel/gdb
+)"
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" srcdir="${S}"
+}
+
+src_test() {
+ emake CFLAGS="${CFLAGS}" srcdir="${S}" check
+}
+
+src_install() {
+ emake DESTDIR="${D}" CFLAGS="${CFLAGS}" srcdir="${S}" install
+}