summaryrefslogtreecommitdiff
path: root/sys-devel/dwz/dwz-0.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sys-devel/dwz/dwz-0.13.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sys-devel/dwz/dwz-0.13.ebuild')
-rw-r--r--sys-devel/dwz/dwz-0.13.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/dwz/dwz-0.13.ebuild b/sys-devel/dwz/dwz-0.13.ebuild
new file mode 100644
index 000000000000..a99b0d53e373
--- /dev/null
+++ b/sys-devel/dwz/dwz-0.13.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="DWARF optimization and duplicate removal tool"
+HOMEPAGE="https://sourceware.org/dwz"
+SRC_URI="https://sourceware.org/ftp/dwz/releases/${P}.tar.xz"
+
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/elfutils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -e '/^CFLAGS/d' -i Makefile || die
+ tc-export CC
+}