summaryrefslogtreecommitdiff
path: root/sys-devel/crossdev/crossdev-20151026-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-devel/crossdev/crossdev-20151026-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-devel/crossdev/crossdev-20151026-r1.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20151026-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20151026-r1.ebuild b/sys-devel/crossdev/crossdev-20151026-r1.ebuild
new file mode 100644
index 000000000000..e13edd3253a3
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20151026-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+inherit eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
+}
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}