summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-11 03:21:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-11 03:21:49 +0000
commitecd86b32a8f0b6be58bbb4b294ce38f1fbd7d3dc (patch)
tree11371cd9091867fc72344384665285aa7a19efd6 /sys-devel/clang-runtime
parentb118032096b3380de251b5de2466f5198fd2930a (diff)
gentoo auto-resync : 11:12:2022 - 03:21:49
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest1
-rw-r--r--sys-devel/clang-runtime/clang-runtime-16.0.0_pre20221210.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index 07b368a01b48..a7ca038fb07c 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -6,4 +6,5 @@ EBUILD clang-runtime-15.0.6.ebuild 766 BLAKE2B db9c38e5d06c9e20d002696b879f61cf7
EBUILD clang-runtime-16.0.0.9999.ebuild 1369 BLAKE2B a25d32189f78e993706138f339ad0645e3042bd283ddc26b4189c117ea2368d0a1c2b09c2f5f538112bcad65fc14dc0d29f16e4d6ff98e3401c3bdb74d59d750 SHA512 c37860675576d51047f5347400753a19469ea0e2e6ff49a3a5ba6e35f5b33372c06ee2ac1e82aa4a681f35e8c186a1ff8eb25a9eccd0ee35e5ab3d57873f40e0
EBUILD clang-runtime-16.0.0_pre20221126.ebuild 1357 BLAKE2B 41fdd4a52628924b2e5a2af2a06126e533749f36e15ff66cea9273d2e0afbc9107ed1656431170a121d59d1c39a8731c8ebd966e7ec53d23a833a95526f20fba SHA512 5919d5f398ba8be49072679cdf84bca0dfe16759a5d148b7f3df322d3c9087adac172c302b96bc6b67dffd5ccacfcca44cc7091bf631c0af16d5685aacc4e7ef
EBUILD clang-runtime-16.0.0_pre20221205.ebuild 1357 BLAKE2B 41fdd4a52628924b2e5a2af2a06126e533749f36e15ff66cea9273d2e0afbc9107ed1656431170a121d59d1c39a8731c8ebd966e7ec53d23a833a95526f20fba SHA512 5919d5f398ba8be49072679cdf84bca0dfe16759a5d148b7f3df322d3c9087adac172c302b96bc6b67dffd5ccacfcca44cc7091bf631c0af16d5685aacc4e7ef
+EBUILD clang-runtime-16.0.0_pre20221210.ebuild 1357 BLAKE2B 41fdd4a52628924b2e5a2af2a06126e533749f36e15ff66cea9273d2e0afbc9107ed1656431170a121d59d1c39a8731c8ebd966e7ec53d23a833a95526f20fba SHA512 5919d5f398ba8be49072679cdf84bca0dfe16759a5d148b7f3df322d3c9087adac172c302b96bc6b67dffd5ccacfcca44cc7091bf631c0af16d5685aacc4e7ef
MISC metadata.xml 661 BLAKE2B 24688c511713ea102b83c71d226d519981b3aee0e05ef7a56d6a80be829efd843194e45cb4fd801f0bb976b6f1976386d6a2b05d2bc907fe2aa42b22b85b7d1f SHA512 2b5ab8783c90795f2e7d1673d876048ed9745f4911fb7a860df56deac13a6dfeba4581a84562eae54eff757c45042ca3fab75c7800313ae61df9ce69780a9294
diff --git a/sys-devel/clang-runtime/clang-runtime-16.0.0_pre20221210.ebuild b/sys-devel/clang-runtime/clang-runtime-16.0.0_pre20221210.ebuild
new file mode 100644
index 000000000000..b20d7b8fec85
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-16.0.0_pre20221210.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+KEYWORDS="~loong"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}