summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-14 22:34:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-14 22:34:48 +0000
commitcc83ac38154440239f732731b8df86ce322c615e (patch)
tree18fc63c9dac77b03150b94ffd85b724863187af3 /sys-devel/clang-runtime
parentdfd7c8230bca447ee0b09dc11150181b0b3148e2 (diff)
gentoo auto-resync : 14:11:2023 - 22:34:48
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest1
-rw-r--r--sys-devel/clang-runtime/clang-runtime-17.0.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index 2d286898dfa6..b2f37ff2aef6 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -2,6 +2,7 @@ EBUILD clang-runtime-14.0.6.ebuild 760 BLAKE2B 0f6cfb8536569ffe2a09305e710563096
EBUILD clang-runtime-15.0.7.ebuild 759 BLAKE2B d7b481faffc4da0a6dc1b4e708322cd17cd497dc75363bdb89e7fbb1ecb2aecd9cbf91bdf816505476c7aca2ec7b6fb9ef178705e6b77361d21a7a270404a70a SHA512 8128acfc92b1601e93ffca1fd4233456f8a28fbc4cc65a1782da25df48abd3af82d0128b31f12b966ca02ab1eafcd28016c4443d9c7f1d28bc3f951cfff5e07f
EBUILD clang-runtime-16.0.6.ebuild 1435 BLAKE2B dfbb6047c0541de72f3447fa61f00d96c2b7c4b96454fa82796f59bd2884ecdbb01539bf08741d3b5ed866b18f4003bca6878cac549b6ef46aa5c6a15bc56c85 SHA512 d63983cb60299866a743ff6b71279b433a10f011fc51e53f3d3d6d6b99dffc080ef0110e21b4dd6b8a54bceb47035d28bf670e6e81fd0939630b593912d77eb5
EBUILD clang-runtime-17.0.4.ebuild 1442 BLAKE2B ccd97064b84899371758ceab7640d2b9a3104e08dccbefc5523062437cec1358ab68773b96bbc8193d8cd52a2bac65e6687cb150127d953aa49ab7f8cb3dbcea SHA512 9b8639788a2bfab9fea6e717e684c4784ae6719ce8d6bb389d16d836df0b43d108be6c649b9aa17dfa60df7b3f490450d4d51e83dd80707467a844871b97535e
+EBUILD clang-runtime-17.0.5.ebuild 1442 BLAKE2B ccd97064b84899371758ceab7640d2b9a3104e08dccbefc5523062437cec1358ab68773b96bbc8193d8cd52a2bac65e6687cb150127d953aa49ab7f8cb3dbcea SHA512 9b8639788a2bfab9fea6e717e684c4784ae6719ce8d6bb389d16d836df0b43d108be6c649b9aa17dfa60df7b3f490450d4d51e83dd80707467a844871b97535e
EBUILD clang-runtime-18.0.0.9999.ebuild 1339 BLAKE2B 60f0ce6dc250d959f058872d748bbffcbf3f036b3546a8c83c8178d809c9699095f84731fd1195b690b2d9b000c0f2a06d95153d1688809c325abe2f80dad88a SHA512 22d8cdc017390809ad96b917a85639a5c0f687db6737217447f49630004b5dffa8468db92a42f5f3e84788365380dd9b707fc03dcb5b4b102ec7f13b764d5d2c
EBUILD clang-runtime-18.0.0_pre20231104.ebuild 1339 BLAKE2B 60f0ce6dc250d959f058872d748bbffcbf3f036b3546a8c83c8178d809c9699095f84731fd1195b690b2d9b000c0f2a06d95153d1688809c325abe2f80dad88a SHA512 22d8cdc017390809ad96b917a85639a5c0f687db6737217447f49630004b5dffa8468db92a42f5f3e84788365380dd9b707fc03dcb5b4b102ec7f13b764d5d2c
EBUILD clang-runtime-18.0.0_pre20231111.ebuild 1339 BLAKE2B 60f0ce6dc250d959f058872d748bbffcbf3f036b3546a8c83c8178d809c9699095f84731fd1195b690b2d9b000c0f2a06d95153d1688809c325abe2f80dad88a SHA512 22d8cdc017390809ad96b917a85639a5c0f687db6737217447f49630004b5dffa8468db92a42f5f3e84788365380dd9b707fc03dcb5b4b102ec7f13b764d5d2c
diff --git a/sys-devel/clang-runtime/clang-runtime-17.0.5.ebuild b/sys-devel/clang-runtime/clang-runtime-17.0.5.ebuild
new file mode 100644
index 000000000000..6483c7c0c78e
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-17.0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}