summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:50:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:50:40 +0100
commita2c1a301b2ea85c230b30ef69ff667f230a1bf88 (patch)
tree72b20e59998ee19c32c86634c05e02790faaf20f /sys-devel/clang-runtime
parent24d75f43d3d4caf76f2448bb277e89a3b3ae0d99 (diff)
gentoo auto-resync : 03:08:2022 - 13:50:40
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest3
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.4.ebuild26
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild2
3 files changed, 29 insertions, 2 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index 20ceb42ddded..6ac3cf30ee02 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -1,4 +1,5 @@
EBUILD clang-runtime-13.0.1.ebuild 704 BLAKE2B a75c3997e7f744e1c50f7672bcd3564229fb1b55b8e2a5dac7ca38e8d390d61b76df6dec7134356ddf6487b63adb613ec7484240681f6c5cec9d7fe41912c353 SHA512 a1d245b587ec92bdca8b557d7e821d5f217bb1866a4804539305068d946c42355b1e84e3491d238b549c24822ad60aa872f761ef4418895b13d68f7574fef9f8
-EBUILD clang-runtime-14.0.6.ebuild 760 BLAKE2B 0f6cfb8536569ffe2a09305e71056309690ad1c8e92543e64025bd5e009eac35018ec22b2c0f80c12f3a527cc7e0bfe4ec1bfcb2dd9dea54106abf46b13e5592 SHA512 580efee12fe0e53447f5644fad248ebded8ae6cd8cb5871cb38bb3148091886b6fb9a57ac712d3158d5c3fc38c043b0bfbf62fc550a609752a42c23e605b0ded
+EBUILD clang-runtime-14.0.4.ebuild 761 BLAKE2B 010c9e0263159894c4f70468235f381ec4101be5c17b848fbb89fd9368289cf9005feab4c3c5d368cf221db341bf10f28105038499ce7af2c3580c00e5d80717 SHA512 f6a10e56f891a7422926ad9a94930cc19bc4fb51b718609e5eff5119b34222626526c5404dcead50425c27f6af86a1abd9aef9e8e521bfeea7fdc97c9c3240fc
+EBUILD clang-runtime-14.0.6.ebuild 761 BLAKE2B 010c9e0263159894c4f70468235f381ec4101be5c17b848fbb89fd9368289cf9005feab4c3c5d368cf221db341bf10f28105038499ce7af2c3580c00e5d80717 SHA512 f6a10e56f891a7422926ad9a94930cc19bc4fb51b718609e5eff5119b34222626526c5404dcead50425c27f6af86a1abd9aef9e8e521bfeea7fdc97c9c3240fc
EBUILD clang-runtime-15.0.0.9999.ebuild 700 BLAKE2B fc3ea6d50378cd569aa9a2a30cae69dfe59524f7c9edf5a4f6e39d5d07568224625ad286e857d7d852aef95903cfe9804f54e83aa093269ca2287f57fba2ebb2 SHA512 0b88353d5a7fda68a034017bac76c37ef36d8477b52f4446e81ff01861d50f1140933b54058ad3a3bfa5cade8d8ad2c86cfe5c580b682a9bb03f2e471d3e99ed
MISC metadata.xml 661 BLAKE2B 24688c511713ea102b83c71d226d519981b3aee0e05ef7a56d6a80be829efd843194e45cb4fd801f0bb976b6f1976386d6a2b05d2bc907fe2aa42b22b85b7d1f SHA512 2b5ab8783c90795f2e7d1673d876048ed9745f4911fb7a860df56deac13a6dfeba4581a84562eae54eff757c45042ca3fab75c7800313ae61df9ce69780a9294
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.4.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.4.ebuild
new file mode 100644
index 000000000000..20942078cf05
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild
index 9837077e6c50..20942078cf05 100644
--- a/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://clang.llvm.org/"
LICENSE="metapackage"
SLOT="$(ver_cut 1-3)"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="+compiler-rt libcxx openmp +sanitize"
REQUIRED_USE="sanitize? ( compiler-rt )"