summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-11 01:37:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-11 01:37:01 +0100
commit179be85ade6b2b47bf362865b5c375969ab5ddc8 (patch)
tree073bcd19b7e1bb84acd2f683936671ee88860970 /sys-devel/clang-runtime
parent948f9476d6a417da6048d4291bf36b0507293d63 (diff)
gentoo auto-resync : 11:10:2022 - 01:37:00
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest1
-rw-r--r--sys-devel/clang-runtime/clang-runtime-16.0.0_pre20221010.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index 7426735cf20e..f1d3b7b58792 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -4,4 +4,5 @@ EBUILD clang-runtime-15.0.2.ebuild 766 BLAKE2B db9c38e5d06c9e20d002696b879f61cf7
EBUILD clang-runtime-15.0.3.9999.ebuild 700 BLAKE2B fc3ea6d50378cd569aa9a2a30cae69dfe59524f7c9edf5a4f6e39d5d07568224625ad286e857d7d852aef95903cfe9804f54e83aa093269ca2287f57fba2ebb2 SHA512 0b88353d5a7fda68a034017bac76c37ef36d8477b52f4446e81ff01861d50f1140933b54058ad3a3bfa5cade8d8ad2c86cfe5c580b682a9bb03f2e471d3e99ed
EBUILD clang-runtime-16.0.0.9999.ebuild 1374 BLAKE2B 9699c87947cae5b33b56d8d2edfc7eb1128f3f9355986f74874e4e8b481fb513e8a52523c8b97cf56db364dff311f7d07afa0acb04d37ba30be2918f24226a81 SHA512 cc6a00e72f472b8d1144dc61ec773b41268ed69fa56330e59185775d6fa242a3b884bc8cd539a80375deb22d42bbf53a30d0bf074e0afb706089e20a23c513f0
EBUILD clang-runtime-16.0.0_pre20221006.ebuild 1374 BLAKE2B 9699c87947cae5b33b56d8d2edfc7eb1128f3f9355986f74874e4e8b481fb513e8a52523c8b97cf56db364dff311f7d07afa0acb04d37ba30be2918f24226a81 SHA512 cc6a00e72f472b8d1144dc61ec773b41268ed69fa56330e59185775d6fa242a3b884bc8cd539a80375deb22d42bbf53a30d0bf074e0afb706089e20a23c513f0
+EBUILD clang-runtime-16.0.0_pre20221010.ebuild 1374 BLAKE2B 9699c87947cae5b33b56d8d2edfc7eb1128f3f9355986f74874e4e8b481fb513e8a52523c8b97cf56db364dff311f7d07afa0acb04d37ba30be2918f24226a81 SHA512 cc6a00e72f472b8d1144dc61ec773b41268ed69fa56330e59185775d6fa242a3b884bc8cd539a80375deb22d42bbf53a30d0bf074e0afb706089e20a23c513f0
MISC metadata.xml 661 BLAKE2B 24688c511713ea102b83c71d226d519981b3aee0e05ef7a56d6a80be829efd843194e45cb4fd801f0bb976b6f1976386d6a2b05d2bc907fe2aa42b22b85b7d1f SHA512 2b5ab8783c90795f2e7d1673d876048ed9745f4911fb7a860df56deac13a6dfeba4581a84562eae54eff757c45042ca3fab75c7800313ae61df9ce69780a9294
diff --git a/sys-devel/clang-runtime/clang-runtime-16.0.0_pre20221010.ebuild b/sys-devel/clang-runtime/clang-runtime-16.0.0_pre20221010.ebuild
new file mode 100644
index 000000000000..3cb2769d40af
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-16.0.0_pre20221010.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}