summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime/clang-runtime-15.0.6.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 19:21:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 19:21:10 +0000
commit1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (patch)
treea22ec1622549507f5333dca366a3b1f3e9af1dca /sys-devel/clang-runtime/clang-runtime-15.0.6.9999.ebuild
parent82020bf7ff936f52f6f1efc646ae374e46b5ed36 (diff)
gentoo auto-resync : 29:11:2022 - 19:21:10
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-15.0.6.9999.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.6.9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.6.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.6.9999.ebuild
new file mode 100644
index 000000000000..e4ff9326ddcb
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.6.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"