summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime/clang-runtime-15.0.4.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-24 15:52:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-24 15:52:10 +0100
commit145ac95c683ecda55a9b2cafc84dced2e9c29e03 (patch)
tree3a7aac2c145afe328a1c610a9ee6d7f5b9fd271d /sys-devel/clang-runtime/clang-runtime-15.0.4.9999.ebuild
parentbb17db5f98333b3c74b4194d1c1136144f693add (diff)
gentoo auto-resync : 24:10:2022 - 15:52:09
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-15.0.4.9999.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.4.9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.4.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.4.9999.ebuild
new file mode 100644
index 000000000000..e4ff9326ddcb
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.4.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"