summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-8.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /sys-devel/clang-common/clang-common-8.0.1.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'sys-devel/clang-common/clang-common-8.0.1.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-8.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-8.0.1.ebuild b/sys-devel/clang-common/clang-common-8.0.1.ebuild
new file mode 100644
index 000000000000..91d38bbf2f5b
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-8.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+MY_P=cfe-${PV/_/}.src
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://github.com/llvm/llvm-project/releases/download/llvmorg-${PV}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/bash-autocomplete.sh" || die
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}