summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-21 09:43:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-21 09:43:30 +0100
commit28e28adc401b344fa5c230e2609c542873c372f8 (patch)
treece600e2ae889fb50ee1d80dd98a1f30886081bcd /sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
parent855f2ab2714a36dd2d3b757890b2449d3e9155f2 (diff)
gentoo auto-resync : 21:08:2023 - 09:43:30
Diffstat (limited to 'sys-devel/clang-common/clang-common-18.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0.9999.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
index aed6e024eff7..abf3150abbd6 100644
--- a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit bash-completion-r1 llvm.org
+inherit bash-completion-r1 llvm.org multilib
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
@@ -169,15 +169,21 @@ src_install() {
EOF
fi
- # We only install config files for ${CHOST} because unprefixed tools
+ # We only install config files for supported ABIs because unprefixed tools
# might be used for crosscompilation where e.g. PIE may not be supported.
# See bug #912237 and bug #901247.
- local tool
- for tool in ${CHOST}-clang{,++,-cpp}; do
- newins - "${tool}.cfg" <<-EOF
- # This configuration file is used by ${tool} driver.
- @gentoo-common.cfg
- EOF
+ # Just ${CHOST} won't do due to bug #912685.
+ local abi
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+
+ local tool
+ for tool in ${abi_chost}-clang{,++,-cpp}; do
+ newins - "${tool}.cfg" <<-EOF
+ # This configuration file is used by ${tool} driver.
+ @gentoo-common.cfg
+ EOF
+ done
done
}