summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-16.0.0_pre20220918.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 17:22:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 17:22:12 +0100
commitb2a3508c3634488d32ec5bbe6b4365ab27185ebd (patch)
tree408b60b91a5427cc1ecb8a441c9df1f2526eeba1 /sys-devel/clang-common/clang-common-16.0.0_pre20220918.ebuild
parent8668c0f6c5fd1d084b8b2bdac1cfa1fcba412f65 (diff)
gentoo auto-resync : 19:09:2022 - 17:22:11
Diffstat (limited to 'sys-devel/clang-common/clang-common-16.0.0_pre20220918.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0_pre20220918.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.0_pre20220918.ebuild b/sys-devel/clang-common/clang-common-16.0.0_pre20220918.ebuild
new file mode 100644
index 000000000000..1285500128bb
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-16.0.0_pre20220918.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+PDEPEND="
+ sys-devel/clang:*
+"
+
+LLVM_COMPONENTS=( clang/utils )
+llvm.org_set_globals
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}