summaryrefslogtreecommitdiff
path: root/sys-devel/boost-m4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
commite59b99df9503539c0231e655a17bccf83f8a270d (patch)
treedbd3fc51c710879436a4122898a3653c8c0d4ae8 /sys-devel/boost-m4
parent9fce2d9787c37a690336f5e345a49d83ee60bc8a (diff)
gentoo auto-resync : 25:06:2023 - 07:29:14
Diffstat (limited to 'sys-devel/boost-m4')
-rw-r--r--sys-devel/boost-m4/Manifest2
-rw-r--r--sys-devel/boost-m4/boost-m4-0.4_p20221019.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/boost-m4/Manifest b/sys-devel/boost-m4/Manifest
index 48c50ea1a717..7daca651a6dd 100644
--- a/sys-devel/boost-m4/Manifest
+++ b/sys-devel/boost-m4/Manifest
@@ -1,3 +1,5 @@
DIST boost-m4-0.4_p20160328.tar.gz 41253 BLAKE2B 47ad17f652560dce4e276b295e55e7daa8752f1c932a6c0d1bad9e4bc2ff72eb0adfaf8abc4e7c57f179f08857de255935fc530f0a4d8a26d3f6a2a0711417ac SHA512 4aecd311b21ced4a3d62fc706a9fa731c375ea490482f78756892243b5af6909cd8841c249632b37820be7f1bde41c290e842edd933d0c727e1dca76d30eb506
+DIST boost-m4-0.4_p20221019.tar.gz 43301 BLAKE2B 8363b4e5406232050017c5272f5954509d784604485e9c5d485fbb360cebfa366bc0732886c13b54935deb6b1a85632c42282e3a51e92082ac3f40a78e43bbbb SHA512 43bf52054ad820d3da12dca38af7e71c80053a09c9dd06a9a5af87e87bafd69e36b891c179353e5c5e63970c38456264176769df6de8719fd6526116e9971dc6
EBUILD boost-m4-0.4_p20160328.ebuild 897 BLAKE2B ba77eee54c3902a4be584f7bce2823f402ec0978963f67d9dfa51bd97b3401f2ec893abd081154781073a0c5db29700cf4a45629f4148a1fe70c999046c8db85 SHA512 66df32f382df3449a1ee419922e222fb697c20ac4d884aeb3ff5d8a9ab71f28f7b36551ea592bfa347c4eb65d7d3c5d8a7a588d6fe723cc32446333b6f175aeb
+EBUILD boost-m4-0.4_p20221019.ebuild 957 BLAKE2B 4625cdc4734bbc3eb02518fc512c32e9e7239ccda8192e20411a051c11775970e93bdf4bdd1e1419d4a24ec1476fe1017c1c634dc278d8b9caa70ec9e5b75585 SHA512 067846a1b1609040b9be8be931a76e014a16de407014b77158bef1fa7e4276b3f87a37f48afb94da4e538476e840c8388ad71f59399ba713077c7570a537fc67
MISC metadata.xml 250 BLAKE2B 403312b0ec65a008648bdfd5d99508ac58533f0b4bb1f91bc11a38c7d24e4e57f11467dd70175a42a2fde1a0665cb01d46ea3fdc9c16a8c642618e58f18d0431 SHA512 795b1de33f3ab0f7d7e8b515f02e0bfb3fd6414dd9256d94b0a3cd0f84270456509b1c9a0b189e257bc3fccd15d73a9bec40ed5ce18a58c78c8e3819ca41a0c7
diff --git a/sys-devel/boost-m4/boost-m4-0.4_p20221019.ebuild b/sys-devel/boost-m4/boost-m4-0.4_p20221019.ebuild
new file mode 100644
index 000000000000..1e9e6c30f506
--- /dev/null
+++ b/sys-devel/boost-m4/boost-m4-0.4_p20221019.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+BOOST_COMMIT="0c955e2c32804d6140676052a9e684ca84bf086d"
+
+DESCRIPTION="Another set of autoconf macros for compiling against boost"
+HOMEPAGE="https://github.com/tsuna/boost.m4"
+SRC_URI="https://github.com/tsuna/boost.m4/archive/${BOOST_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN/-/.}-${BOOST_COMMIT}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# boost.m4 has a buildsystem, but the distributer didn't use make dist
+# so we'd have to eautoreconf to use it. Also, its ./configure script
+# DEPENDs on boost. For installing one file, bootstrapping the
+# buildsystem isn't worth it.
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins build-aux/boost.m4
+
+ dodoc AUTHORS NEWS README THANKS
+}