summaryrefslogtreecommitdiff
path: root/sys-devel/bmake/bmake-20220726.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-31 15:12:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-31 15:12:39 +0100
commit2cfae1fadeca2d0c51a301318c96c2cf5073eb6f (patch)
tree711cd9c9044cc9edd306df0c2c17f06558024a29 /sys-devel/bmake/bmake-20220726.ebuild
parent100ce16c6fb75a4911f388aa77f860324607c869 (diff)
gentoo auto-resync : 31:07:2022 - 15:12:39
Diffstat (limited to 'sys-devel/bmake/bmake-20220726.ebuild')
-rw-r--r--sys-devel/bmake/bmake-20220726.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-devel/bmake/bmake-20220726.ebuild b/sys-devel/bmake/bmake-20220726.ebuild
new file mode 100644
index 000000000000..5505e007c65a
--- /dev/null
+++ b/sys-devel/bmake/bmake-20220726.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MK_VER=20210330
+
+DESCRIPTION="NetBSD's portable make"
+HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
+SRC_URI="
+ http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
+ http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# Skip failing test (sandbox and csh)
+PATCHES=(
+ "${FILESDIR}"/${PN}-20210206-tests.patch
+ "${FILESDIR}"/${PN}-20220418-warnings.patch
+)
+
+src_prepare() {
+ default
+ cd "${WORKDIR}" || die
+ eapply "${FILESDIR}"/${PN}-20210314-mk-fixes.patch
+}
+
+src_configure() {
+ econf \
+ --with-mksrc=../mk \
+ --with-default-sys-path="${EPREFIX}"/usr/share/mk/${PN} \
+ --with-machine_arch=${ARCH}
+}
+
+src_compile() {
+ sh make-bootstrap.sh || die "bootstrap failed"
+}
+
+src_test() {
+ cd unit-tests || die
+
+ # the 'ternary' test uses ${A} internally, which
+ # conflicts with Gentoo's ${A}, hence unset it for
+ # the tests temporarily.
+ env -u A MAKEFLAGS= \
+ "${S}"/bmake -r -m / TEST_MAKE="${S}"/bmake test || die "tests compilation failed"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ FORCE_BSD_MK=1 SYS_MK_DIR=. \
+ sh ../mk/install-mk -v -m 644 "${ED}"/usr/share/mk/${PN} \
+ || die "failed to install mk files"
+}