summaryrefslogtreecommitdiff
path: root/sys-devel/bison
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
commitfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (patch)
tree3669828a2d0c5f7cb1a4bfd79be8032aac558282 /sys-devel/bison
parent9bc9c4dcc38dc560cff8e5d083d1e5f282ddde98 (diff)
gentoo auto-resync : 03:12:2022 - 02:58:11
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/Manifest1
-rw-r--r--sys-devel/bison/bison-3.8.2-r1.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index ab3762053b22..c16fb6160b44 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -3,5 +3,6 @@ DIST bison-3.7.6.tar.xz 2627180 BLAKE2B 2f1015b517e46ff0870378b4d0dd489c8c737f31
DIST bison-3.8.2.tar.xz 2817324 BLAKE2B e211b61494c911f55b72a8b70b5a48cdf4000ce9e675a1f1f52735bb8f57d93a3f8075341451263af9c9c531004907ae2b62b1873e7e4664c2cd26fa3b12271c SHA512 d4d23af6671406e97257892f90651b67f2ab95219831372be032190b7156c10a3435d457857e677445df8b2327aacccc15344acbbc3808a6f332a93cce23b444
DIST bison-3.8.2.tar.xz.sig 195 BLAKE2B b9bd21adb5115d3d3174c94223fbc9cd33afa0e9c1805008e49f77ff154fc2b656d8a9e9503dc5290658ae2948a2ca7c0dbc812f62aec268d8f8bfafb6349096 SHA512 8bb7743ca326e81a6c091b1413e3c09bd43c7eabbb80bac0638ccd52bdf7e3395cce300a86acd95f4637a9ec8a1b0e9a4d3d25d95ab0a8f03e57fd82eb87a7ac
EBUILD bison-3.7.6.ebuild 2434 BLAKE2B 151aa4bdf6746f02d0c5ad4a6132bf1d50b86ff2c9850b5395d99c829efa7f2b67c630bb7c12c7670172c346a7751353a0178a0589349eef5164e018dbac3551 SHA512 eceabaf5749358483b0b34379f2f4738fa4c5e1adaa3c272990b10a97ace8a2f7213ad0ff0357b73eeccc2f950d46b8ce1580db2ccbd225bcd33d95bf7dbdd93
+EBUILD bison-3.8.2-r1.ebuild 2646 BLAKE2B 6bd72f90daf2894a1bcbe1fd8a7329f2d01ef3934f1be07da492064c3c46b5a9a12d3956939e625263d68ba82c1bf47f22ed9553e53ce8d0459a0e863c630f7b SHA512 8d0fbdc6a6a880d8f98db761b053e4be732db4f367417460d03e185da86a83642e6ac36ad4db24011a4a1c5a762bb3db5fcfba686c7494ce300b68407c84f08d
EBUILD bison-3.8.2.ebuild 2683 BLAKE2B 1d8c260254727f4c8d219128f52b40d3652f96c23b1e7467b6437c86b6b170f4e585f51b160f5232002a14fa3420818432a48dacd6d0a7935f7df2b015894901 SHA512 3ae1bfdbb736c5c0ba540efb3a012dc91064423aeaa9d8ca7dd113178d97de5192302d328cb5c783c6a67f0ff78980c8ca4fa4822acc1cd5aaa905edbcb3b7e6
MISC metadata.xml 387 BLAKE2B 68154e64265d54f0d48f427088369e7e4757adbecdb4a33a426940cac3d8680ec902460577d2fca55ad4febdf43b5713a0743051b89e7c7a1f918f5e93974152 SHA512 099f1a7dd7e95828cdd44a082d933637db8ba2a787b11791733615e20852ff43228f0744c65e8e552d15a0bcc874690d2ed53a4a1b564f6e923c12475f1b0708
diff --git a/sys-devel/bison/bison-3.8.2-r1.ebuild b/sys-devel/bison/bison-3.8.2-r1.ebuild
new file mode 100644
index 000000000000..8a3490b4631a
--- /dev/null
+++ b/sys-devel/bison/bison-3.8.2-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/bison.asc
+inherit flag-o-matic verify-sig
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
+
+# gettext _IS_ required in RDEPEND because >=bison-3.7 links against
+# libtextstyle.so!!! (see bug #740754)
+DEPEND="
+ >=sys-devel/m4-1.4.16
+ >=sys-devel/gettext-0.21
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/flex
+ test? ( dev-lang/perl )
+ verify-sig? ( sec-keys/openpgp-keys-bison )
+"
+PDEPEND="app-alternatives/yacc"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) # ChangeLog-2012 ChangeLog-1998 PACKAGING README-alpha README-release
+
+src_prepare() {
+ # Old logic when we needed to patch configure.ac
+ # Keeping in case it's useful for future
+
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ #touch -r configure.ac old.configure.ac || die
+ #touch -r configure old.configure || die
+
+ #eapply "${WORKDIR}"/patches
+ #default
+
+ # Restore date after patching
+ #touch -r old.configure.ac configure.ac || die
+ #touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ #touch doc/bison.1 || die #548778 #538300#9
+
+ default
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ $(use_enable nls)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # These are owned by app-alternatives/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+
+ # Examples are about 200K, so let's make them optional still for now.
+ if ! use examples ; then
+ rm -r "${ED}"/usr/share/doc/${PF}/examples/ || die
+ fi
+}
+
+pkg_postinst() {
+ # ensure to preserve the symlinks before app-alternatives/yacc
+ # is installed
+ if [[ ! -h ${EROOT}/usr/bin/yacc ]]; then
+ ln -s yacc "${EROOT}/usr/bin/yacc.bison" || die
+ fi
+}