summaryrefslogtreecommitdiff
path: root/sys-devel/binutils/binutils-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-11 02:19:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-11 02:19:03 +0100
commit995884416efaa899e9abe8d5c6899570e518b84b (patch)
treeb80d7fe7cc1e5e48e899d459fa62594665af4eb5 /sys-devel/binutils/binutils-9999.ebuild
parentf1cd8f3514f8b9fbc1cc9cfe0dd08a8cb258e87a (diff)
gentoo auto-resync : 11:08:2022 - 02:19:03
Diffstat (limited to 'sys-devel/binutils/binutils-9999.ebuild')
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index c3d9de773f3a..c2ab796642a4 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -316,7 +316,7 @@ src_compile() {
emake V=1 info
fi
- use emacs && elisp-compile "${S}"/binutils/dwarf-mode.el
+ ! is_cross && use emacs && elisp-compile "${S}"/binutils/dwarf-mode.el
# we nuke the manpages when we're left with junk
# (like when we bootstrap, no perl -> no manpages)
@@ -419,7 +419,7 @@ src_install() {
dodoc opcodes/ChangeLog*
fi
- if use emacs ; then
+ if ! is_cross && use emacs ; then
elisp-install ${PN} "${S}"/binutils/dwarf-mode.el{,c}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
@@ -436,7 +436,7 @@ pkg_postinst() {
[[ -e ${EROOT}/etc/env.d/binutils/config-${CTARGET} ]] && return 0
binutils-config ${CTARGET}-${PV}
- use emacs && elisp-site-regen
+ ! is_cross && use emacs && elisp-site-regen
}
pkg_postrm() {
@@ -461,7 +461,7 @@ pkg_postrm() {
binutils-config ${CTARGET}-${PV}
fi
- use emacs && elisp-site-regen
+ ! is_cross && use emacs && elisp-site-regen
}
# Note [slotting support]