summaryrefslogtreecommitdiff
path: root/sys-devel/binutils/binutils-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-04 09:17:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-04 09:17:06 +0100
commit5e0e6a28799c4a5134e55d203b373f1d6811c004 (patch)
tree6512a6801267b6752a4b464d52debaecb9caeedd /sys-devel/binutils/binutils-9999.ebuild
parentf71e91f3fbcdebf01a5ecf58164716586daeaa5b (diff)
gentoo auto-resync : 04:08:2023 - 09:17:05
Diffstat (limited to 'sys-devel/binutils/binutils-9999.ebuild')
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index d553da58aa63..11e84c53af1c 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -250,6 +250,11 @@ src_configure() {
--libdir="${EPREFIX}"${LIBPATH}
--libexecdir="${EPREFIX}"${LIBPATH}
--includedir="${EPREFIX}"${INCPATH}
+ # portage's econf() does not detect presence of --d-d-t
+ # because it greps only top-level ./configure. But not
+ # libiberty's or bfd's configure.
+ --disable-dependency-tracking
+ --disable-silent-rules
--enable-obsolete
--enable-shared
--enable-threads
@@ -335,7 +340,7 @@ src_configure() {
fi
fi
- ECONF_SOURCE="${S}" econf "${myconf[@]}" || die
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
# Prevent makeinfo from running if doc is unset.
if ! use doc ; then
@@ -349,11 +354,11 @@ src_compile() {
cd "${MY_BUILDDIR}" || die
# see Note [tooldir hack for ldscripts]
- emake V=1 tooldir="${EPREFIX}${TOOLPATH}" all
+ emake tooldir="${EPREFIX}${TOOLPATH}" all
# only build info pages if the user wants them
if use doc ; then
- emake V=1 info
+ emake info
fi
# we nuke the manpages when we're left with junk
@@ -367,7 +372,7 @@ src_test() {
# bug #637066
filter-flags -Wall -Wreturn-type
- emake -k V=1 check
+ emake -k check
}
src_install() {
@@ -376,7 +381,7 @@ src_install() {
cd "${MY_BUILDDIR}" || die
# see Note [tooldir hack for ldscripts]
- emake V=1 DESTDIR="${D}" tooldir="${EPREFIX}${LIBPATH}" install
+ emake DESTDIR="${D}" tooldir="${EPREFIX}${LIBPATH}" install
rm -rf "${ED}"/${LIBPATH}/bin || die
use static-libs || find "${ED}" -name '*.la' -delete