summaryrefslogtreecommitdiff
path: root/sys-devel/bin86
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /sys-devel/bin86
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'sys-devel/bin86')
-rw-r--r--sys-devel/bin86/Manifest2
-rw-r--r--sys-devel/bin86/bin86-0.16.21-r1.ebuild34
-rw-r--r--sys-devel/bin86/files/bin86-0.16.21-amd64-build.patch19
3 files changed, 55 insertions, 0 deletions
diff --git a/sys-devel/bin86/Manifest b/sys-devel/bin86/Manifest
index 938b1c817ab7..f086ed3cdc5a 100644
--- a/sys-devel/bin86/Manifest
+++ b/sys-devel/bin86/Manifest
@@ -1,4 +1,6 @@
AUX bin86-0.16.17-amd64-build.patch 327 BLAKE2B 076e7fb11802f082f94f3e688553ae9f561609ae6675c67105ee9a30292185edd12b90a5149bc34ba6d6a453ce7648943c732a865bb238a4ebe5e8185ce6ed51 SHA512 8e4102c5b0848249c69fd9b3f16a93b12bbe8dce9771b78514bf423bec7b0144677f4eae07cb0ea479bf03dbd21092fdb2ce0a028df95f28c37d48b660466c13
+AUX bin86-0.16.21-amd64-build.patch 398 BLAKE2B c9457b574beceac90ba1ae5207b4164426f731252c0e728901ab6ee628a570c4ca95a4395e53b6a3f73fa41107678dd766185daa158e99e6ec609ae026ea48fa SHA512 d7be4857acf46ee6dd803048726083b471dc302c7189c64acf71e00923d736ebe9174a87ed0f90f5eb71221c35c18f2259f0f62a47f8e64c682a6d7afcf2504d
DIST bin86-0.16.21.tar.gz 154283 BLAKE2B 6c88a5cf86623130f6ed45cefb9ee9293d8888f4d0e5712d96a24a6fe84bbe5002869761e9c39bb20c8af74e3fe76cf65632ef43e55d81d0e5cb9212f3cae56a SHA512 e80e06965fbdcf13100aae4690071d01a6efe74aed7ff8f14e5892c6803393a1b5acda1296e0f0e1837dfb73e0edd02e9cccfeabbeabe1b68fa6b6b85ced1f56
+EBUILD bin86-0.16.21-r1.ebuild 839 BLAKE2B 6eecb19c6033d79e056d7d0958cd9fb6f563ec6212192489271bd0b49ccada960c1a2283b1ca2e52d02e8173bf5d4a40b84ea0d716f5a0ce744d1ac515685fcb SHA512 7bbc87ab86117b04d209220ef80de9b5cc38f6a1af4619c33f8a1d8ed49ceaff38cf49824a2e746c1e0b084d5c981df86a1c87aaf917e5086c55932fcb64d3bc
EBUILD bin86-0.16.21.ebuild 855 BLAKE2B 7a13609b50ddc239fc1ca03e21bada1a45b7eecc73127cf16dd8323572fc43dc14f7a033b5d5ac364903d5e495136b159231266fbd16219d5e28e006708c2387 SHA512 96d3a8d61e02c3039f9197313ea88aadbf991aea9626226621992cf924e1b34cd1ab49fa664b102bf92e2a43859761572f5ea56d05c0c8e19a73cc9979e0bce4
MISC metadata.xml 243 BLAKE2B 88a8c5cbe0638cb7bdd3ddd42933def8a1cd34061ea459a0fc0bf392b72a0555955bd0812488b7024933258fb38f82c4fffaf8cb981a609c2d26f999520d44c5 SHA512 3232362e301749801c78b456fa395a8dd155629d5d06a22a4929ab29405e2ffdf1f1a77414d7c069b30456b87b3909c7c73684b9b44f9cf1e47eff0306c88928
diff --git a/sys-devel/bin86/bin86-0.16.21-r1.ebuild b/sys-devel/bin86/bin86-0.16.21-r1.ebuild
new file mode 100644
index 000000000000..c8aa201710f6
--- /dev/null
+++ b/sys-devel/bin86/bin86-0.16.21-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Assembler and loader used to create kernel bootsector"
+HOMEPAGE="http://v3.sk/~lkundrak/dev86/"
+SRC_URI="http://v3.sk/~lkundrak/dev86/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+PATCHES="${FILESDIR}"/${PN}-0.16.21-amd64-build.patch
+
+src_prepare() {
+ use elibc_musl && CPPFLAGS="${CPPFLAGS} -U__linux__"
+ sed -i \
+ -e '/^PREFIX/s|=.*|=$(DESTDIR)/usr|' \
+ -e '/^MANDIR/s|)/man/man1|)/share/man/man1|' \
+ -e '/^INSTALL_OPTS/s|-s||' \
+ -e "/^CFLAGS/s|=.*|=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}|" \
+ -e "/^LDFLAGS/s|=.*|=${LDFLAGS}|" \
+ Makefile || die
+ tc-export CC
+ default
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ default
+}
diff --git a/sys-devel/bin86/files/bin86-0.16.21-amd64-build.patch b/sys-devel/bin86/files/bin86-0.16.21-amd64-build.patch
new file mode 100644
index 000000000000..9e5a85299fe6
--- /dev/null
+++ b/sys-devel/bin86/files/bin86-0.16.21-amd64-build.patch
@@ -0,0 +1,19 @@
+This should make it built on other archictectures as well
+
+https://bugs.gentoo.org/428228
+
+diff --git a/ld/x86_aout.h b/ld/x86_aout.h
+index 542a70d..a38488d 100644
+--- a/ld/x86_aout.h
++++ b/ld/x86_aout.h
+@@ -19,7 +19,9 @@ typedef long Long;
+ typedef int32_t Long;
+ #define __OUT_OK 1
+ #else
+-typedef char Long[4];
++#define __OUT_OK 1
++#include <inttypes.h>
++typedef int32_t Long;
+ #endif
+ #endif
+