summaryrefslogtreecommitdiff
path: root/sys-devel/automake/automake-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 09:09:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 09:09:34 +0100
commitad0412d0cafb8c04ce98024155cf99a4cc27db44 (patch)
treec34688ab389c18775a322de6cd4cfd957cbe8014 /sys-devel/automake/automake-9999.ebuild
parentcdb747b791914a30c287a3a8e33d1b635e431707 (diff)
gentoo auto-resync : 30:07:2022 - 09:09:33
Diffstat (limited to 'sys-devel/automake/automake-9999.ebuild')
-rw-r--r--sys-devel/automake/automake-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sys-devel/automake/automake-9999.ebuild b/sys-devel/automake/automake-9999.ebuild
index 0467aa671d75..a36fa3529b35 100644
--- a/sys-devel/automake/automake-9999.ebuild
+++ b/sys-devel/automake/automake-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit python-any-r1
@@ -23,6 +23,7 @@ else
# Alpha/beta releases are not distributed on the usual mirrors.
SRC_URI="https://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
fi
+
S="${WORKDIR}/${MY_P}"
fi
@@ -53,14 +54,15 @@ pkg_setup() {
src_prepare() {
default
+
export WANT_AUTOCONF=2.5
- # Don't try wrapping the autotools this thing runs as it tends
+ # Don't try wrapping the autotools - this thing runs as it tends
# to be a bit esoteric, and the script does `set -e` itself.
./bootstrap || die
sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
- # Bug 628912
- if ! has_version sys-apps/texinfo ; then
+ # bug #628912
+ if ! has_version -b sys-apps/texinfo ; then
touch doc/{stamp-vti,version.texi,automake.info} || die
fi
}
@@ -70,8 +72,8 @@ src_configure() {
default
}
-# slot the info pages. do this w/out munging the source so we don't have
-# to depend on texinfo to regen things. #464146 (among others)
+# Slot the info pages. Do this w/out munging the source so we don't have
+# to depend on texinfo to regen things. bug #464146 (among others)
slot_info_pages() {
pushd "${ED}"/usr/share/info >/dev/null || die
rm -f dir