summaryrefslogtreecommitdiff
path: root/sys-devel/autogen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-09 16:32:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-09 16:32:24 +0000
commit3f5a5d10d87cd7f434c3a4207fc0a7ffc25d9123 (patch)
tree3d2de0ea329bfae5fb1acd465386966d5ee95422 /sys-devel/autogen
parent91b873ea3e20149dbb554dc214611efa4627962a (diff)
gentoo auto-resync : 09:11:2023 - 16:32:23
Diffstat (limited to 'sys-devel/autogen')
-rw-r--r--sys-devel/autogen/Manifest1
-rw-r--r--sys-devel/autogen/autogen-5.18.16-r2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-devel/autogen/Manifest b/sys-devel/autogen/Manifest
index ac64618dd816..e7ccea351813 100644
--- a/sys-devel/autogen/Manifest
+++ b/sys-devel/autogen/Manifest
@@ -6,4 +6,5 @@ AUX autogen-5.18.16-rpath.patch 2990 BLAKE2B 8374f788feee898f35f6baae40d0a42a042
DIST autogen-5.18.16-gnulib-3b57ddee0acffd23cc51bc8910a15cf879f90619-lib-verify.h 11231 BLAKE2B 4f38f6ae84cf5cc4ba47d8a7da3b38b06f58e30ac8b70f2b10936cbb7a775179b67f22ca8e636588515c4ace7410f98835218e3222d4a793378cdafc4aa84d0f SHA512 b8ff80fd764a3f21040b0054e71a443e3d9ec18dd631843f2de999aa54776964b36366b35fd158dbbe5f2ece146fab12c6ff5008e18c52188b718c89972f867b
DIST autogen-5.18.16.tar.xz 1046276 BLAKE2B 23f9e0948f24ada715fb2bcbbfecba768cf51d169ea3ff4724a97b18f598d2d7fb2ffa7e23919ec8dcc0e352f9d3280f3740dab279a0af1412919cf10c6cb0bf SHA512 5f12c982dbe27873f5649a96049bf019ff183c90cc0c8a9196556b0ca02e72940cd422f6d6601f68cc7d8763b1124f2765c3b1a6335fc92ba07f84b03d2a53a1
EBUILD autogen-5.18.16-r1.ebuild 2179 BLAKE2B ff3c00f51e6987aadf1913a70161457438ddc7990bc88f01d13ad3a79ecb3f7b1af905a490b0e25016fa981670aa57522afecc975af000a7093e301c6ede5c6a SHA512 e02e57585d3b46675c01018aa00652a4632a7b80cbe24d2b1f94664f4a7bafcb53adaacd0a60cc38e36033139edcb9392d9974a7749bb3865f18a108b21d9f8f
+EBUILD autogen-5.18.16-r2.ebuild 2014 BLAKE2B 8df702391ab6c7f9b3fa21142e846a0bf1abf2743e05ec8a43d35c2678a9679f98ceeb341fb257c5e67508131cf7951e2cff8f1674eada2f0f5a6feac5c55ae2 SHA512 94e3df3faf7c50b1f134051c2ac724ddd84c10ea2baae823709e2958a44689579339d0ae966829f7a78920a72f1521ea944b24872a8cd0f8adabc6f265e107f5
MISC metadata.xml 465 BLAKE2B d749ac3e74b39a006006e3f8d09ca2e8dd392f05385ffaf4d4d4cc95af4571c48e6ff6383e5f582ed6158d3536c9d9447c8f9587a8dc8ad9bce3ea3d5f8b2b5a SHA512 da4398891bf5ddd30545e5ca15b1591da5126d0ae22d00a5d5851864351c43465e6eac9010a9e35a029eb3009727fcd3264cb4fa87fd1f6545639f90b9cf2a47
diff --git a/sys-devel/autogen/autogen-5.18.16-r2.ebuild b/sys-devel/autogen/autogen-5.18.16-r2.ebuild
new file mode 100644
index 000000000000..487d7daf8150
--- /dev/null
+++ b/sys-devel/autogen/autogen-5.18.16-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Program and text file generation"
+HOMEPAGE="https://www.gnu.org/software/autogen/"
+SRC_URI="
+ mirror://gnu/${PN}/rel${PV}/${P}.tar.xz
+ https://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=blob_plain;f=lib/verify.h;h=3b57ddee0acffd23cc51bc8910a15cf879f90619;hb=537a5511ab0b1326e69b32f87593a50aedb8a589 -> ${P}-gnulib-3b57ddee0acffd23cc51bc8910a15cf879f90619-lib-verify.h
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libopts static-libs"
+
+RDEPEND="
+ >=dev-scheme/guile-2.0:=
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}"
+# TODO: investigate & drop this!
+BDEPEND="sys-apps/which"
+
+# We don't pass the flag explicitly, bug #796776.
+# Let's fix it upstream after next autogen release if it happens.
+QA_CONFIGURE_OPTIONS+=" --enable-snprintfv-convenience"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.18.16-no-werror.patch
+ "${FILESDIR}"/${PN}-5.18.16-rpath.patch
+ "${FILESDIR}"/${PN}-5.18.16-respect-TMPDIR.patch
+ "${FILESDIR}"/${PN}-5.18.16-make-4.3.patch
+ "${FILESDIR}"/${PN}-5.18.16-guile-3.patch
+)
+
+src_prepare() {
+ default
+
+ # missing tarball file
+ cp "${DISTDIR}"/${P}-gnulib-3b57ddee0acffd23cc51bc8910a15cf879f90619-lib-verify.h autoopts/verify.h || die
+
+ # May be able to drop this on next release (>5.18.16)
+ eautoreconf
+}
+
+src_configure() {
+ # suppress possibly incorrect -R flag
+ export ag_cv_test_ldflags=
+
+ # autogen requires run-time sanity of regex and string functions.
+ # Use defaults of linux-glibc until we need somethig more advanced.
+ if tc-is-cross-compiler ; then
+ export ag_cv_run_strcspn=no
+ export libopts_cv_with_libregex=yes
+ fi
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if ! use libopts ; then
+ rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
+ fi
+}