summaryrefslogtreecommitdiff
path: root/sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-24 19:36:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-24 19:36:06 +0000
commit8c39538f1e5cf37f42c409a6c742f96abef56f3b (patch)
treefeb0b0792d417455747892f388078029dd6aee66 /sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild
parentba4938837d52c0aff763d8acdc03ce103dd3ff82 (diff)
gentoo auto-resync : 24:12:2023 - 19:36:06
Diffstat (limited to 'sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild')
-rw-r--r--sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild18
1 files changed, 17 insertions, 1 deletions
diff --git a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild
index e5e60776090a..9e8d6199ae93 100644
--- a/sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild
+++ b/sys-devel/autoconf-vanilla/autoconf-vanilla-2.69.ebuild
@@ -10,11 +10,18 @@ else
MY_PN=${PN/-vanilla}
MY_P=${MY_PN}-${PV}
+ # Eric Blake signed 2.69 so use sec-keys/openpgp-keys-m4
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/m4.asc
+ inherit verify-sig
+
SRC_URI="
mirror://gnu/${MY_PN}/${MY_P}.tar.xz
https://dev.gentoo.org/~polynomial-c/dist/${MY_P}-runstatedir_patches.tar.xz
+ verify-sig? ( mirror://gnu/${MY_PN}/${MY_P}.tar.xz.sig )
"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-m4 )"
fi
S="${WORKDIR}"/${MY_P}
@@ -28,7 +35,7 @@ LICENSE="GPL-3+"
SLOT="${PV}"
IUSE="emacs"
-BDEPEND="
+BDEPEND+="
>=sys-devel/m4-1.4.16
>=dev-lang/perl-5.6
"
@@ -53,6 +60,15 @@ PATCHES=(
TC_AUTOCONF_ENVPREFIX=07
+src_unpack() {
+ if use verify-sig ; then
+ # Needed for downloaded patch (which is unsigned, which is fine)
+ verify-sig_verify_detached "${DISTDIR}"/${MY_P}.tar.xz{,.sig}
+ fi
+
+ default
+}
+
src_prepare() {
# usr/bin/libtool is provided by binutils-apple, need gnu libtool
if [[ ${CHOST} == *-darwin* ]] ; then