summaryrefslogtreecommitdiff
path: root/sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20230114.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
commit1ac83daac7198a5717483e1cfab669ba4f12debe (patch)
treefb9c448591e3f43e411800a609df633313aab78f /sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20230114.ebuild
parentfddb33ccaadabe03f5571606f796b45965b38e9c (diff)
gentoo auto-resync : 16:04:2023 - 05:49:50
Diffstat (limited to 'sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20230114.ebuild')
-rw-r--r--sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20230114.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20230114.ebuild b/sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20230114.ebuild
new file mode 100644
index 000000000000..96b243b974c0
--- /dev/null
+++ b/sys-devel/autoconf-dickey/autoconf-dickey-2.52_p20230114.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: adapt toolchain-autoconf to take econf args?
+# TODO: review our old autoconf-2.52 patches?
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+MY_P=${PN/-dickey}-${PV/_p/-}
+DESCRIPTION="Fork of sys-devel/autoconf for Thomas Dickey's packages"
+HOMEPAGE="https://invisible-island.net/autoconf/autoconf.html"
+SRC_URI="https://invisible-island.net/archives/autoconf/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/autoconf/${MY_P}.tgz.asc )"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=sys-devel/m4-1.4.16
+ >=dev-lang/perl-5.6
+"
+BDEPEND="
+ ${RDEPEND}
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+src_prepare() {
+ # usr/bin/libtool is provided by binutils-apple, need gnu libtool
+ #if [[ ${CHOST} == *-darwin* ]] ; then
+ # PATCHES+=( "${FILESDIR}"/${PN}-2.61-darwin.patch )
+ #fi
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --datadir="${EPREFIX}"/usr/share/${PN}
+ --program-suffix=-dickey
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # -j1 for bug #869278
+ emake -j1 check
+}