summaryrefslogtreecommitdiff
path: root/sys-cluster
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-30 01:13:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-30 01:13:30 +0000
commitd9ec8de250ddc362ca4726cd6c055216b529177a (patch)
tree41583a3d39640bf31918130f91d9f94f0c59b9b0 /sys-cluster
parent62090949b4fde34bbcbb4bd770a9635c6ac0c55e (diff)
gentoo auto-resync : 30:03:2024 - 01:13:30
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/Manifest.gzbin11390 -> 11385 bytes
-rw-r--r--sys-cluster/sanlock/Manifest2
-rw-r--r--sys-cluster/sanlock/sanlock-3.8.5.ebuild17
3 files changed, 13 insertions, 6 deletions
diff --git a/sys-cluster/Manifest.gz b/sys-cluster/Manifest.gz
index aa034e1762d0..cc6a93c7ea5a 100644
--- a/sys-cluster/Manifest.gz
+++ b/sys-cluster/Manifest.gz
Binary files differ
diff --git a/sys-cluster/sanlock/Manifest b/sys-cluster/sanlock/Manifest
index eabecda1da6c..35841df93685 100644
--- a/sys-cluster/sanlock/Manifest
+++ b/sys-cluster/sanlock/Manifest
@@ -5,5 +5,5 @@ AUX wdmd.initd 261 BLAKE2B 65b393f2f084896d3c17aa0345f9930badeec7a3ee4cc7e47bd0a
DIST sanlock-3.8.4.tar.gz 270031 BLAKE2B da011a15d488849d47fe1043df040580652558918dff9549bf4e6cb4077c03b4aaa8f8de5399dbb0e3f2301ae90c0d20599b25bd5e72bae5317b13f79a352333 SHA512 9fca2b18fd3bd504d5186de0b2626ea2c993997528de2384dc042afe52b2b68422a2e4bb79e2409c9e6eccbe5ea8d8939549eb25c5d16aa7fecf6c9a5798340c
DIST sanlock-3.8.5.tar.gz 270911 BLAKE2B 7f8146d67c620d22ded5205c1c621f3bbb36256a4c80e866575d8f324ad0237cf8bc07579f3aeda393dd0db85e27fdaa1aab1b6d7b931d4416d13f82d560e22a SHA512 8131e0b37ac47052a29d4b3a3e4286b06b862f08e827d3307f179eadbe97e4bc3e10f5c93f35042c308435ee81546a813227bce665a9735cbbf2b5a4a1f4474a
EBUILD sanlock-3.8.4-r1.ebuild 1872 BLAKE2B 9aad2a68c9ca9a960288ba985521471f74ceb24a702fbd5b16d1cac61730aa05b9a67b3af87af10c67bef512e04f699dfe7a7f6c7fba216c40bb448f32a8aa04 SHA512 318363502db84de37f6fb28362607b1a63f9beee4c1ccb17221859530c21edbe76c060cda48394d11035716b7b817a5f24275bf28093a7196be2bd97e3a25466
-EBUILD sanlock-3.8.5.ebuild 1872 BLAKE2B a03c14e7ac67363889e882b36e30a8aaf693e84b88d13af1ff91df1df2cf58701328faa4f287814d2983669b78f54dcfd2b03c798823664a3698575856f63176 SHA512 8c7321068b8a0790afe568542de5032ea8b331133991c7d24d0c7110c93aa282a8ac155793c9938c2f4974438b73dff1d7cbd13b781d8dcaa8c387f0267f7d1c
+EBUILD sanlock-3.8.5.ebuild 2002 BLAKE2B 70c3ad04da130ae10ce6a6bd82e2d4f080d549476faf517989d9bf4ae3727760cdd3db25ce5986951e15ab1cbe1e163592a851ef4c544d39fd8822b8cb718267 SHA512 6f8d4b28fa2ff6106ff30a20550cac867fb6ceb4580704ce6ae799be96037506bc5919e7e30ce9292f1996fefb5e1336495647c9a3cc055431942b7a61d3d778
MISC metadata.xml 369 BLAKE2B a32cbc5e109bab37912ecc7efe951fcec96fb133b2861d3c38290e5f3aabe87e444d38bdbb18b711ba5836c43c7ac7ebcde3b5f23ec10df8c413cbd445c05ddf SHA512 ac7cb5f13743775baecae83e2c6beb6988b4c374db96217136cd68124e947890de32c9d7afecbdafbac32b0ac450ec2580b923f0e9fb63ef944463e879cd8283
diff --git a/sys-cluster/sanlock/sanlock-3.8.5.ebuild b/sys-cluster/sanlock/sanlock-3.8.5.ebuild
index 74db35ff3d2c..1616fa1a3a73 100644
--- a/sys-cluster/sanlock/sanlock-3.8.5.ebuild
+++ b/sys-cluster/sanlock/sanlock-3.8.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit linux-info python-r1 systemd
+inherit flag-o-matic linux-info python-r1 systemd
DESCRIPTION="shared storage lock manager"
HOMEPAGE="https://pagure.io/sanlock"
@@ -18,13 +18,15 @@ IUSE="python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
- acct-user/${PN}
- acct-group/${PN}
dev-libs/libaio
sys-apps/util-linux
python? ( ${PYTHON_DEPS} )
"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ acct-user/${PN}
+ acct-group/${PN}
+ ${DEPEND}
+"
BDEPEND="sys-apps/which"
PATCHES=(
@@ -35,6 +37,11 @@ PATCHES=(
CONFIG_CHECK="~SOFT_WATCHDOG"
src_compile() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/863734
+ # https://pagure.io/sanlock/issue/10
+ filter-lto
+
for d in wdmd src fence_sanlock reset; do
emake -C ${d}
done