summaryrefslogtreecommitdiff
path: root/sys-cluster/ucx/ucx-1.10.0_rc5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sys-cluster/ucx/ucx-1.10.0_rc5.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sys-cluster/ucx/ucx-1.10.0_rc5.ebuild')
-rw-r--r--sys-cluster/ucx/ucx-1.10.0_rc5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-cluster/ucx/ucx-1.10.0_rc5.ebuild b/sys-cluster/ucx/ucx-1.10.0_rc5.ebuild
new file mode 100644
index 000000000000..1d3c4a64a113
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.10.0_rc5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="https://www.openucx.org"
+
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/openucx/ucx/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}