summaryrefslogtreecommitdiff
path: root/sys-cluster/swift
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /sys-cluster/swift
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'sys-cluster/swift')
-rw-r--r--sys-cluster/swift/Manifest1
-rw-r--r--sys-cluster/swift/swift-2018.1.9999.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/sys-cluster/swift/Manifest b/sys-cluster/swift/Manifest
index 1c7a28eddf3c..659e417d62cc 100644
--- a/sys-cluster/swift/Manifest
+++ b/sys-cluster/swift/Manifest
@@ -9,4 +9,5 @@ EBUILD swift-2.15.1-r1.ebuild 3698 BLAKE2B 8a94b57c4c58456438491f9a7e1ba5891c932
EBUILD swift-2.16.0.ebuild 3698 BLAKE2B 971a44109dc7fbc2230be6db33db966eb1596969953bb1ce03d9133683223f9c17553602397d5555dc88515e6dc5c283f829903ffbfcef1cd63c2cf855c9d8ef SHA512 5fa5c18cd19412aae6e41a544058b29cde20c3a9d84c89c27767ec7f8bff4021a559562e44bbd11b722fd6950b3529734ec42ab9a8bee930e6200160b873953e
EBUILD swift-2.17.0.ebuild 3700 BLAKE2B 5b55b5ecb033383dec349f3476d3ed873d00e048d237ec1b56189751dbe1a8b4d28e20a6bbe12461f6fc2ed9a5910d86e4e8c86bbb3cfd672558ec8fab9eaf96 SHA512 3a2b3cfe88c8979046514dbeb597ebdea9bf453c0dcb5e3a607fc2e3136e572d122b3b988597211adf686d095d3e98eb79e495f49005028e7d68f8e92eb18ebe
EBUILD swift-2017.2.9999.ebuild 3711 BLAKE2B 1ede70612136464f13d35f97decc571eb37b28e2bbb9a5414e0b0d74d14bdc5d68e54123e74e066fa4eaeb4071b19816415faccf524b4a4aef79aa7709b2ffc0 SHA512 9aaf45d59410e93fe55c9aacdd2c0de697ce6d076af71b703b7c51df14eecf5fb1edc0d0e62a95240092a624f586a7e79167b33688087a2363208f22f4191bff
+EBUILD swift-2018.1.9999.ebuild 3838 BLAKE2B ad33e64ef8a647ab8a253dca63cec07046180fcff33c75d0e117c13ac1ca6a0eb6610408199fef664d128ca69083431d72a4562cdcc7d8d529e1900f422afd94 SHA512 69e036871b6ed85745f6a88199554f3b3113c39e529a80a093b6675cc0a99ca243ee8f29daea5e620d7a03726e5c9317a47edac7df8e0a8fa0e99b806169ae04
MISC metadata.xml 898 BLAKE2B 3d502769ba44cdc1e3a500929d60a1ed82d8540297b2dfddb6d6745ec9b5b56bd9fe7130a738858b9bac653b49634efae1841600325194d69ec30222b2e8b3f2 SHA512 3f9d2cf7538fe32010b811d3a49802eb085dde793b29d9590fe3032d63a743f620e3c1dcf1226b59aa5938ea239f440997a3d4d489f9887816621879e19a0c4c
diff --git a/sys-cluster/swift/swift-2018.1.9999.ebuild b/sys-cluster/swift/swift-2018.1.9999.ebuild
new file mode 100644
index 000000000000..2cf086833fec
--- /dev/null
+++ b/sys-cluster/swift/swift-2018.1.9999.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils linux-info user
+
+DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
+HOMEPAGE="https://launchpad.net/swift"
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openstack/swift.git"
+ EGIT_BRANCH="stable/pike"
+else
+ SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="proxy account container object +memcached"
+REQUIRED_USE="|| ( proxy account container object )"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/dnspython-1.14.0:0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.5[${PYTHON_USEDEP}]
+ !~dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
+ !~dev-python/netifaces-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/pyxattr[${PYTHON_USEDEP}]
+ >=dev-python/PyECLib-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.6.0[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-2.0[${PYTHON_USEDEP}]
+ memcached? ( net-misc/memcached )
+ net-misc/rsync[xattr]"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
+ ~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
+ ~ZFS"
+ if linux_config_exists; then
+ for module in ${CONFIG_CHECK}; do
+ linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
+ done
+ fi
+}
+
+pkg_setup() {
+ enewuser swift
+ enewgroup swift
+}
+
+src_prepare() {
+ sed -i 's/xattr/pyxattr/g' requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+src_test () {
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
+ SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ keepdir /etc/swift
+ insinto /etc/swift
+
+ newins "etc/swift.conf-sample" "swift.conf"
+ newins "etc/rsyncd.conf-sample" "rsyncd.conf"
+ newins "etc/mime.types-sample" "mime.types-sample"
+ newins "etc/memcache.conf-sample" "memcache.conf-sample"
+ newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
+ newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
+
+ if use proxy; then
+ newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
+ newins "etc/proxy-server.conf-sample" "proxy-server.conf"
+ if use memcached; then
+ sed -i '/depend/a\
+ need memcached' "${D}/etc/init.d/swift-proxy"
+ fi
+ fi
+ if use account; then
+ newinitd "${FILESDIR}/swift-account.initd" "swift-account"
+ newins "etc/account-server.conf-sample" "account-server.conf"
+ fi
+ if use container; then
+ newinitd "${FILESDIR}/swift-container.initd" "swift-container"
+ newins "etc/container-server.conf-sample" "container-server.conf"
+ fi
+ if use object; then
+ newinitd "${FILESDIR}/swift-object.initd" "swift-object"
+ newins "etc/object-server.conf-sample" "object-server.conf"
+ newins "etc/object-expirer.conf-sample" "object-expirer.conf"
+ fi
+
+ fowners root:swift "/etc/swift" || die "fowners failed"
+ fperms 0750 /etc/swift
+}
+
+pkg_postinst() {
+ elog "Openstack swift will default to using insecure http unless a"
+ elog "certificate is created in /etc/swift/cert.crt and the associated key"
+ elog "in /etc/swift/cert.key. These can be created with the following:"
+ elog " * cd /etc/swift"
+ elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
+}