summaryrefslogtreecommitdiff
path: root/sys-cluster/sanlock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /sys-cluster/sanlock
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'sys-cluster/sanlock')
-rw-r--r--sys-cluster/sanlock/Manifest2
-rw-r--r--sys-cluster/sanlock/sanlock-3.6.0.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-cluster/sanlock/Manifest b/sys-cluster/sanlock/Manifest
index e06f5f09bd97..4ced44c7ac22 100644
--- a/sys-cluster/sanlock/Manifest
+++ b/sys-cluster/sanlock/Manifest
@@ -1,5 +1,7 @@
AUX sanlock.initd 249 BLAKE2B 18bafba28ab4449c7f25ab2d14b4ac2d3cc89cf79bfb8f802fd180584becde8a5b9d919ac9ab887a4ebdfe8ea64e53f30b3785bc32875ccd2e25fa99a9278081 SHA512 5ed7b2d96cb875e2db0914ec7232fe8443c05de69e07d214ffc0adfafac5123694173373f831c5acf46d11aa4fca304b88e6e4c4ee2fbe5b033d173eea5aec36
AUX wdmd.initd 261 BLAKE2B 65b393f2f084896d3c17aa0345f9930badeec7a3ee4cc7e47bd0a35e47c18ea2bcf5afdc386c0da98988bc9fae479a68b504c244b55ab389ac7f5304c34282ae SHA512 9c7e980817c1c76868caff229b42a3d70e912abfd8c974bf5b856067bef79fbd3a5942b30bcb7d02869e2eba85e6f6ba3c861e9780046b01b25df1b39661b6c0
DIST sanlock-3.4.0.tar.xz 157016 BLAKE2B 9d588214d260b88cfa3978e831bcd8086ae80aafc1a04b616274da141140a22c2765083632f29402cdae67cdbbdfcefdaff1539e5d45485c6f271e3ee7f6471a SHA512 8a10faaa5b9ce9f0506ca16620ad482804c9ca860b84a60a6f0b525a256059229a202163d366a57fb59169c0f4f822ced570b42562e412747f6f716509341f19
+DIST sanlock-3.6.0.tar.gz 221666 BLAKE2B 7fe95bd6813c13b76993b343a5ad605c7ba642583987ffa5fef583f34c053ee62b0f9e5979f5b5cb9e4fcde53268ae3debc5ec36b04f6651cc4cb902dff52df9 SHA512 59eb2a6f12e95d54886fdf6d56fd9a6814dd20fe11f39664f2bb82a56326fee48c9465ae30e6d04f970c8f1b0d9c2e22b90d21ab1f657c6d6b61ff9f02332443
EBUILD sanlock-3.4.0-r1.ebuild 2096 BLAKE2B c6c12a9cdb99d5189158fbf336c61745740e830d94688b60de1d3dcc04a702503fdd5195c5f28d6755e02d875641b4320d5add2a025a15e941883a98f1f3b1e6 SHA512 d346383b90da585faf2b681db960e0b47ed3b444fec6bc582b8d8b4806832ad6a7ecf0a4fa942dd61677097a61b93971b5e43f3983a87d5f400c3491594b5790
+EBUILD sanlock-3.6.0.ebuild 2077 BLAKE2B 387dc7aced94052f625e5bd4676ea4862430c55ff18deb39c7fe5eb5da3ff1897e6c8e9e719bfa76d8f867110e14cd4a3100e6009492f538e64d2479927f7fd0 SHA512 ceadb102f9748192c0e3522dd91c0a55d00c7f511c1f745af97c70c4ba4d20d12177a27b1c0eb572894391dc5264dc222dfd2d56b6a7ab74f4dd69279a84b8c9
MISC metadata.xml 368 BLAKE2B a15a411ea20eb7649f299e38704b394344194d7526f9bc92b27c0a26760d7dba05b1e5d483ff5f9ce73a6d1cd527a18ac905344a614c8dc31a0c1180b2be07e7 SHA512 2cc3ec3c99cfff2e0c576ab6c7b0a39460af875ba826ce0cf3c5a1a4f0f3def6170753c8d42af2fc7a139ad7f2135e309c3165bde83b4e7574292768c96e8086
diff --git a/sys-cluster/sanlock/sanlock-3.6.0.ebuild b/sys-cluster/sanlock/sanlock-3.6.0.ebuild
new file mode 100644
index 000000000000..a2ff725e30e2
--- /dev/null
+++ b/sys-cluster/sanlock/sanlock-3.6.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit linux-info python-r1 systemd user
+
+DESCRIPTION="shared storage lock manager"
+HOMEPAGE="https://pagure.io/sanlock"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+ GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-libs/libaio
+ sys-apps/util-linux
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local warning="You need to have CONFIG_SOFT_WATCHDOG enabled in your kernel for wdmd"
+ if linux_config_exists; then
+ if ! linux_chkconfig_present SOFT_WATCHDOG; then
+ ewarn ""
+ ewarn "$warning"
+ ewarn ""
+ fi
+ else
+ ewarn ""
+ ewarn "Could not be checked automatically: $warning"
+ ewarn ""
+ fi
+}
+
+pkg_preinst() {
+ enewgroup sanlock
+ enewuser sanlock -1 -1 -1 sanlock,disk
+
+}
+
+src_compile() {
+ for d in wdmd src fence_sanlock reset; do
+ cd $d; emake; cd ..
+ done
+ if use python; then
+ cd python; python_foreach_impl emake; cd ..
+ fi
+}
+
+src_install() {
+ for d in wdmd src fence_sanlock reset; do
+ cd $d; emake DESTDIR="${D}" LIBDIR="${EROOT}usr/$(get_libdir)" install; cd ..
+ done
+ if use python; then
+ cd python; python_foreach_impl emake DESTDIR="${D}" install; cd ..
+ fi
+
+ # config
+ dodir /etc/wdmd.d
+ dodir /etc/sanlock
+ insinto /etc/sanlock
+ doins src/sanlock.conf
+
+ # init
+ newconfd init.d/sanlock.sysconfig sanlock
+ newconfd init.d/wdmd.sysconfig wdmd
+ newinitd "${FILESDIR}"/sanlock.initd sanlock
+ newinitd "${FILESDIR}"/wdmd.initd wdmd
+ #doinitd ${FILESDIR}/sanlk-resetd.initd
+ #doinitd ${FILESDIR}/fence_sanlockd.initd
+
+ # systemd
+ systemd_newunit init.d/sanlock.service.native sanlock.service
+ sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native
+ systemd_newunit init.d/wdmd.service.native wdmd.service
+ systemd_dounit init.d/sanlk-resetd.service
+ #systemd_dounit ${FILESDIR}/fence_sanlockd.service
+}