summaryrefslogtreecommitdiff
path: root/sys-cluster/sanlock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 17:26:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 17:26:08 +0100
commit3cf27339901a7ca15df33f6ea134daa93888d5d0 (patch)
treed0f451df94a8ce90e3e81be8816e5f3ed8e62138 /sys-cluster/sanlock
parentf6a034d922bf54efeaa781fcb5388b325b90d945 (diff)
gentoo auto-resync : 03:05:2023 - 17:26:08
Diffstat (limited to 'sys-cluster/sanlock')
-rw-r--r--sys-cluster/sanlock/Manifest2
-rw-r--r--sys-cluster/sanlock/sanlock-3.8.5.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/sys-cluster/sanlock/Manifest b/sys-cluster/sanlock/Manifest
index 2bd3d9a1927f..1f19b063b163 100644
--- a/sys-cluster/sanlock/Manifest
+++ b/sys-cluster/sanlock/Manifest
@@ -3,5 +3,7 @@ AUX sanlock-fence_sanlock-LDFLAGS.patch 504 BLAKE2B 11176057304ee5f841500921f1fa
AUX sanlock.initd 249 BLAKE2B 18bafba28ab4449c7f25ab2d14b4ac2d3cc89cf79bfb8f802fd180584becde8a5b9d919ac9ab887a4ebdfe8ea64e53f30b3785bc32875ccd2e25fa99a9278081 SHA512 5ed7b2d96cb875e2db0914ec7232fe8443c05de69e07d214ffc0adfafac5123694173373f831c5acf46d11aa4fca304b88e6e4c4ee2fbe5b033d173eea5aec36
AUX wdmd.initd 261 BLAKE2B 65b393f2f084896d3c17aa0345f9930badeec7a3ee4cc7e47bd0a35e47c18ea2bcf5afdc386c0da98988bc9fae479a68b504c244b55ab389ac7f5304c34282ae SHA512 9c7e980817c1c76868caff229b42a3d70e912abfd8c974bf5b856067bef79fbd3a5942b30bcb7d02869e2eba85e6f6ba3c861e9780046b01b25df1b39661b6c0
DIST sanlock-3.8.4.tar.gz 270031 BLAKE2B da011a15d488849d47fe1043df040580652558918dff9549bf4e6cb4077c03b4aaa8f8de5399dbb0e3f2301ae90c0d20599b25bd5e72bae5317b13f79a352333 SHA512 9fca2b18fd3bd504d5186de0b2626ea2c993997528de2384dc042afe52b2b68422a2e4bb79e2409c9e6eccbe5ea8d8939549eb25c5d16aa7fecf6c9a5798340c
+DIST sanlock-3.8.5.tar.gz 270911 BLAKE2B 7f8146d67c620d22ded5205c1c621f3bbb36256a4c80e866575d8f324ad0237cf8bc07579f3aeda393dd0db85e27fdaa1aab1b6d7b931d4416d13f82d560e22a SHA512 8131e0b37ac47052a29d4b3a3e4286b06b862f08e827d3307f179eadbe97e4bc3e10f5c93f35042c308435ee81546a813227bce665a9735cbbf2b5a4a1f4474a
EBUILD sanlock-3.8.4-r1.ebuild 1872 BLAKE2B 9aad2a68c9ca9a960288ba985521471f74ceb24a702fbd5b16d1cac61730aa05b9a67b3af87af10c67bef512e04f699dfe7a7f6c7fba216c40bb448f32a8aa04 SHA512 318363502db84de37f6fb28362607b1a63f9beee4c1ccb17221859530c21edbe76c060cda48394d11035716b7b817a5f24275bf28093a7196be2bd97e3a25466
+EBUILD sanlock-3.8.5.ebuild 1879 BLAKE2B b36eae9163cd49c45a026818b253dced79625a60985a84c64e171def2b493fc71ac5ebed03df804f755aa3fd9a71cbe336a9c99784ce395d2164c6e5e1211702 SHA512 6dbb2911d770e867e7f7a9919131770771a5e3e98c98bad384d03f7b9cd115bc1c35082d10e84778b9f86fb4624f30eb89cbb6f5669bd51f679b21205a6746ee
MISC metadata.xml 369 BLAKE2B a32cbc5e109bab37912ecc7efe951fcec96fb133b2861d3c38290e5f3aabe87e444d38bdbb18b711ba5836c43c7ac7ebcde3b5f23ec10df8c413cbd445c05ddf SHA512 ac7cb5f13743775baecae83e2c6beb6988b4c374db96217136cd68124e947890de32c9d7afecbdafbac32b0ac450ec2580b923f0e9fb63ef944463e879cd8283
diff --git a/sys-cluster/sanlock/sanlock-3.8.5.ebuild b/sys-cluster/sanlock/sanlock-3.8.5.ebuild
new file mode 100644
index 000000000000..d2fee0f662f4
--- /dev/null
+++ b/sys-cluster/sanlock/sanlock-3.8.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit linux-info python-r1 systemd
+
+DESCRIPTION="shared storage lock manager"
+HOMEPAGE="https://pagure.io/sanlock"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+ GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ acct-user/${PN}
+ acct-group/${PN}
+ dev-libs/libaio
+ sys-apps/util-linux
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-apps/which"
+
+PATCHES=(
+ "${FILESDIR}/sanlock-fence_sanlock-LDFLAGS.patch"
+ "${FILESDIR}/sanlock-3.8.4-implicit-func-decls.patch"
+)
+
+CONFIG_CHECK="~SOFT_WATCHDOG"
+
+src_compile() {
+ for d in wdmd src fence_sanlock reset; do
+ emake -C ${d}
+ done
+
+ if use python; then
+ python_foreach_impl emake -C python
+ fi
+}
+
+src_install() {
+ for d in wdmd src fence_sanlock reset; do
+ emake -C ${d} DESTDIR="${D}" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ done
+
+ if use python; then
+ python_foreach_impl emake -C python DESTDIR="${D}" install
+ fi
+
+ # config
+ dodir /etc/wdmd.d
+ dodir /etc/sanlock
+ insinto /etc/sanlock
+ doins src/sanlock.conf
+
+ # init
+ newconfd init.d/sanlock.sysconfig sanlock
+ newconfd init.d/wdmd.sysconfig wdmd
+ newinitd "${FILESDIR}"/sanlock.initd sanlock
+ newinitd "${FILESDIR}"/wdmd.initd wdmd
+ #doinitd ${FILESDIR}/sanlk-resetd.initd
+ #doinitd ${FILESDIR}/fence_sanlockd.initd
+
+ # systemd
+ systemd_newunit init.d/sanlock.service.native sanlock.service
+ sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native || die
+ systemd_newunit init.d/wdmd.service.native wdmd.service
+ systemd_dounit init.d/sanlk-resetd.service
+ #systemd_dounit ${FILESDIR}/fence_sanlockd.service
+}