summaryrefslogtreecommitdiff
path: root/sys-cluster/rdma-core/rdma-core-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /sys-cluster/rdma-core/rdma-core-9999.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'sys-cluster/rdma-core/rdma-core-9999.ebuild')
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
index a4b748ab4b1d..a8c381b38698 100644
--- a/sys-cluster/rdma-core/rdma-core-9999.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -31,7 +31,11 @@ COMMON_DEPEND="
python? ( ${PYTHON_DEPS} )"
DEPEND="${COMMON_DEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
RDEPEND="${COMMON_DEPEND}
!!sys-fabric/infiniband-diags
@@ -90,4 +94,6 @@ src_install() {
newinitd "${FILESDIR}"/ibacm.init ibacm
newinitd "${FILESDIR}"/iwpmd.init iwpmd
newinitd "${FILESDIR}"/srpd.init srpd
+
+ use python && python_optimize
}