summaryrefslogtreecommitdiff
path: root/sys-cluster/openmpi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 13:53:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 13:53:29 +0000
commit00ac4b34406552b4fbca786be59b2983b7f58669 (patch)
treeff2e5facaa5f92566a0362c881beaa9bacb567a0 /sys-cluster/openmpi
parent32b8124b0a5827960601f2183a970103b3d231b7 (diff)
gentoo auto-resync : 19:12:2023 - 13:53:29
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/Manifest2
-rw-r--r--sys-cluster/openmpi/openmpi-4.1.6.ebuild166
2 files changed, 168 insertions, 0 deletions
diff --git a/sys-cluster/openmpi/Manifest b/sys-cluster/openmpi/Manifest
index 992f07292398..045aa1eb0859 100644
--- a/sys-cluster/openmpi/Manifest
+++ b/sys-cluster/openmpi/Manifest
@@ -1,5 +1,7 @@
DIST openmpi-4.1.4.tar.bz2 10042839 BLAKE2B b020e3530ae5dde7b144e7c33b1a3f26f622526a4b48a97a0956fc6f49bbf9dfd5be9ebeeaf3bdc5168a307507408ba5dd8e2a537148821e1d476678177dc5d6 SHA512 c70a92c9b16b8c76a871183f9b180d60861186e64140da897d206d53bc06213f31ea93b31734645f580f4bf28dda5605d85dbce2417e4596955384d961bed653
DIST openmpi-4.1.5.tar.bz2 10045426 BLAKE2B 135a8373ed6173b7a94def18e3b964c6b6050c909382e0dbb1898a6d261ae428931358121ef6d325d303f4f510017a94970f7c66b280a5fc460365821f36dece SHA512 7a2188684ed7542fe42e1717ae72cb859b4f3d6f722c9d3ba04bfed6c2178b3e7da3a536629d312c23571fed4d9b2ca5e20e85898ae5144e9332bd898e6e1cc6
+DIST openmpi-4.1.6.tar.bz2 10017002 BLAKE2B 4f119e1ed9b8787f0f860295ab1721fe2fd5300b8e182230a9eba3a864680b02bbd30618cc6d798a693a121626fc0ad5f447144d9ba91becb734f1a530d7a23a SHA512 0ef3240f9c436fb19b67e836cac376eafeb7825d12de3387dad04329dee9f182799d17d785ea23eba763810f479015bb5230593c28950b616b2f0aa1c0a81e71
EBUILD openmpi-4.1.4-r1.ebuild 5762 BLAKE2B 0c8676d3022a92f821af5fb5f3c6fa998ab5f33140a64a474aa99e754c2e2195d5c63f093d68e3427a63f3860e4773403c49147eb8133535e8956003a63d17ca SHA512 de45e955cde2aba3c163a6e7b98d3eb37fa1fb7ef00663582d601a69574a16e64901dfe10729bf4ecbde45925d764f2504073e7a41524b2405139d9969cd0c0a
EBUILD openmpi-4.1.5.ebuild 5067 BLAKE2B 67ccc424b75c4dcbaae33931b8438afd0e00d6b3ba451dcbcc267a36e7b673af381f5766963acc7b7561d3d3e7a278f4c88e95dcb5b5ec69c0a74aa81dbe4932 SHA512 aab66c7556d7cb7e85fc60c23f16438a9627b86efcb2339776a3546a24f09157bc5fb24d3a81bc585ec2ab800ada6eef5c9f79485d435960b49f950c0232bdfc
+EBUILD openmpi-4.1.6.ebuild 5067 BLAKE2B 67ccc424b75c4dcbaae33931b8438afd0e00d6b3ba451dcbcc267a36e7b673af381f5766963acc7b7561d3d3e7a278f4c88e95dcb5b5ec69c0a74aa81dbe4932 SHA512 aab66c7556d7cb7e85fc60c23f16438a9627b86efcb2339776a3546a24f09157bc5fb24d3a81bc585ec2ab800ada6eef5c9f79485d435960b49f950c0232bdfc
MISC metadata.xml 669 BLAKE2B 9a3c719cdf956edf19133d2de7f1b31ffd3c84c1d306dda80dc8969e827a4dd37b424fa61fcc1ec0952505a1f3903ff1fed729dab9ef30659623232bc86b0373 SHA512 ae2850b743676a2a98aa7e1414607aace499eb435e745b3751babcf92cc3485cc825f4069cdf539cfcb591db3d80796ce84bb09430bc07adb8b935d60306d795
diff --git a/sys-cluster/openmpi/openmpi-4.1.6.ebuild b/sys-cluster/openmpi/openmpi-4.1.6.ebuild
new file mode 100644
index 000000000000..6f827b726524
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-4.1.6.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+inherit cuda fortran-2 multilib-minimal
+
+MY_P=${P/-mpi}
+
+IUSE_OPENMPI_FABRICS="
+ openmpi_fabrics_ofed
+ openmpi_fabrics_knem"
+
+IUSE_OPENMPI_RM="
+ openmpi_rm_pbs
+ openmpi_rm_slurm"
+
+IUSE_OPENMPI_OFED_FEATURES="
+ openmpi_ofed_features_control-hdr-padding
+ openmpi_ofed_features_udcm
+ openmpi_ofed_features_rdmacm
+ openmpi_ofed_features_dynamic-sl"
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="https://www.open-mpi.org"
+SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="cma cuda cxx fortran ipv6 libompitrace peruse romio valgrind
+ ${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
+
+REQUIRED_USE="
+ openmpi_rm_slurm? ( !openmpi_rm_pbs )
+ openmpi_rm_pbs? ( !openmpi_rm_slurm )
+ openmpi_ofed_features_control-hdr-padding? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_udcm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_rdmacm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_dynamic-sl? ( openmpi_fabrics_ofed )"
+
+RDEPEND="
+ !sys-cluster/mpich
+ !sys-cluster/mpich2
+ !sys-cluster/nullmpi
+ >=dev-libs/libevent-2.0.22:=[${MULTILIB_USEDEP},threads(+)]
+ dev-libs/libltdl:0[${MULTILIB_USEDEP}]
+ >=sys-apps/hwloc-2.0.2:=[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1:= )
+ openmpi_fabrics_ofed? ( sys-cluster/rdma-core )
+ openmpi_fabrics_knem? ( sys-cluster/knem )
+ openmpi_rm_pbs? ( sys-cluster/torque )
+ openmpi_rm_slurm? ( sys-cluster/slurm )
+ openmpi_ofed_features_rdmacm? ( sys-cluster/rdma-core )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/mpi.h
+ /usr/include/openmpi/mpiext/mpiext_cuda_c.h
+)
+
+pkg_setup() {
+ fortran-2_pkg_setup
+
+ elog
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ elog
+}
+
+src_prepare() {
+ default
+
+ # Avoid test which ends up looking at system mounts
+ echo "int main() { return 0; }" > test/util/opal_path_nfs.c || die
+
+ # Necessary for scalibility, see
+ # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
+ echo 'oob_tcp_listen_mode = listen_thread' \
+ >> opal/etc/openmpi-mca-params.conf || die
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-mpi-java
+ # configure takes a looooong time, but upstream currently force
+ # constriants on caching:
+ # https://github.com/open-mpi/ompi/blob/9eec56222a5c98d13790c9ee74877f1562ac27e8/config/opal_config_subdir.m4#L118
+ # so no --cache-dir for now.
+ --enable-mpi-fortran=$(usex fortran all no)
+ --enable-orterun-prefix-by-default
+ --enable-pretty-print-stacktrace
+
+ --sysconfdir="${EPREFIX}/etc/${PN}"
+
+ --with-hwloc="${EPREFIX}/usr"
+ --with-hwloc-libdir="${EPREFIX}/usr/$(get_libdir)"
+ --with-libltdl="${EPREFIX}/usr"
+ --with-libevent="${EPREFIX}/usr"
+ --with-libevent-libdir="${EPREFIX}/usr/$(get_libdir)"
+
+ # Re-enable for 5.0!
+ # See https://github.com/open-mpi/ompi/issues/9697#issuecomment-1003746357
+ # and https://bugs.gentoo.org/828123#c14
+ --disable-heterogeneous
+
+ $(use_enable cxx mpi-cxx)
+ $(use_enable ipv6)
+ $(use_enable libompitrace)
+ $(use_enable peruse)
+ $(use_enable romio io-romio)
+
+ $(use_with cma)
+
+ $(multilib_native_use_enable openmpi_ofed_features_control-hdr-padding openib-control-hdr-padding)
+ $(multilib_native_use_enable openmpi_ofed_features_rdmacm openib-rdmacm)
+ $(multilib_native_use_enable openmpi_ofed_features_udcm openib-udcm)
+ $(multilib_native_use_enable openmpi_ofed_features_dynamic-sl openib-dynamic-sl)
+
+ $(multilib_native_use_with cuda cuda "${EPREFIX}"/opt/cuda)
+ $(multilib_native_use_with valgrind)
+ $(multilib_native_use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr)
+ $(multilib_native_use_with openmpi_fabrics_knem knem "${EPREFIX}"/usr)
+ $(multilib_native_use_with openmpi_rm_pbs tm)
+ $(multilib_native_use_with openmpi_rm_slurm slurm)
+ )
+
+ CONFIG_SHELL="${BROOT}"/bin/bash ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1
+}
+
+multilib_src_install() {
+ default
+
+ # fortran header cannot be wrapped (bug #540508), workaround part 1
+ if multilib_is_native_abi && use fortran; then
+ mkdir "${T}"/fortran || die
+ mv "${ED}"/usr/include/mpif* "${T}"/fortran || die
+ else
+ # some fortran files get installed unconditionally
+ rm \
+ "${ED}"/usr/include/mpif* \
+ "${ED}"/usr/bin/mpif* \
+ || die
+ fi
+}
+
+multilib_src_install_all() {
+ # fortran header cannot be wrapped (bug #540508), workaround part 2
+ if use fortran; then
+ mv "${T}"/fortran/mpif* "${ED}"/usr/include || die
+ fi
+
+ # Remove la files, no static libs are installed and we have pkg-config
+ find "${ED}" -name '*.la' -delete || die
+
+ einstalldocs
+}