summaryrefslogtreecommitdiff
path: root/sys-cluster/open-mx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/open-mx/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/open-mx/files')
-rw-r--r--sys-cluster/open-mx/files/omxoed.initd45
-rw-r--r--sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch14
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-cluster/open-mx/files/omxoed.initd b/sys-cluster/open-mx/files/omxoed.initd
new file mode 100644
index 000000000000..765842ed7f68
--- /dev/null
+++ b/sys-cluster/open-mx/files/omxoed.initd
@@ -0,0 +1,45 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+checksystem() {
+ if [ -c /dev/open-mx ]; then
+ einfo "Open-MX module already loaded"
+ return 0
+ else
+ einfo "Checking if Open-MX module present"
+ if [ "x$(modprobe -l open-mx | grep open-mx)" == "x" ]; then
+ eerror "open-mx not found!"
+ return 1
+ fi
+ fi
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ checksystem || return 1
+ if [ ! -c /dev/open-mx ]; then
+ ebegin "Loading open-mx module"
+ modprobe -q open-mx
+ fi
+ start-stop-daemon --start --exec /usr/bin/omxoed \
+ --background --make-pidfile \
+ --pidfile /var/run/omeoed.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec /usr/bin/omxoed \
+ --pidfile /var/run/omeoed.pid
+ eend $?
+}
+
+status() {
+ ebegin "Showing current active Open-MX peers"
+ omx_info -q
+}
diff --git a/sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch b/sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch
new file mode 100644
index 000000000000..e082865c235a
--- /dev/null
+++ b/sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch
@@ -0,0 +1,14 @@
+--- Makefile.am 2011-07-15 02:42:53.000000000 +0400
++++ Makefile.am 2011-07-15 02:43:02.000000000 +0400
+@@ -20,11 +20,6 @@
+
+ SUBDIRS =
+
+-# Driver
+-if OMX_BUILD_DRIVER
+- SUBDIRS += driver/linux
+-endif
+-
+ # Library
+ if OMX_BUILD_LIBRARY
+ SUBDIRS += libopen-mx tools tests tests/mx