summaryrefslogtreecommitdiff
path: root/sys-cluster/libquo/libquo-1.2.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/libquo/libquo-1.2.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/libquo/libquo-1.2.4-r1.ebuild')
-rw-r--r--sys-cluster/libquo/libquo-1.2.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-cluster/libquo/libquo-1.2.4-r1.ebuild b/sys-cluster/libquo/libquo-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..ca89f8c78fe2
--- /dev/null
+++ b/sys-cluster/libquo/libquo-1.2.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD=90
+
+inherit autotools-utils fortran-2
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/lanl/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="https://lanl.github.io/${PN}/dists/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="run-time tuning of process binding policies made easy"
+HOMEPAGE="https://lanl.github.io/libquo/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="fortran static-libs"
+
+DEPEND="
+ virtual/mpi[fortran?]
+ sys-process/numactl
+ sys-apps/hwloc[numa,xml]
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-utils_src_configure CC=mpicc FC=$(usex fortran mpif90 false)
+}