summaryrefslogtreecommitdiff
path: root/sys-cluster/libcircle/libcircle-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /sys-cluster/libcircle/libcircle-0.3.0.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'sys-cluster/libcircle/libcircle-0.3.0.ebuild')
-rw-r--r--sys-cluster/libcircle/libcircle-0.3.0.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/sys-cluster/libcircle/libcircle-0.3.0.ebuild b/sys-cluster/libcircle/libcircle-0.3.0.ebuild
index 1193a7cab64f..afe8e3a3425a 100644
--- a/sys-cluster/libcircle/libcircle-0.3.0.ebuild
+++ b/sys-cluster/libcircle/libcircle-0.3.0.ebuild
@@ -1,37 +1,34 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/hpc/${PN}/releases/download/v0.3/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux"
-fi
-
DESCRIPTION="API for distributing embarrassingly parallel workloads using self-stabilization"
HOMEPAGE="https://github.com/hpc/libcircle"
+SRC_URI="https://github.com/hpc/libcircle/releases/download/v$(ver_cut 1-2)/${P}.tar.gz"
-SLOT="0"
LICENSE="BSD"
-IUSE="doc static-libs test"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc test"
RESTRICT="!test? ( test )"
RDEPEND="virtual/mpi"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
test? ( dev-libs/check )"
+BDEPEND="doc? ( app-doc/doxygen )"
src_configure() {
econf \
+ --disable-static \
$(use_enable doc doxygen) \
- $(use_enable static-libs static) \
$(use_enable test tests)
}
src_install() {
- use doc && HTML_DOCS=( "${S}/doc/html/." )
+ use doc && HTML_DOCS=( doc/html/. )
default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}