summaryrefslogtreecommitdiff
path: root/sys-cluster/legion/legion-18.02.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
commit0bff53119f08d677db6c1a991bd30741682a8a08 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /sys-cluster/legion/legion-18.02.0.ebuild
parent6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (diff)
Revert "gentoo resync : 02.06.2018"
This reverts commit 6c14fa2586d9e9c4427b5f727dc6c8ab77587cec.
Diffstat (limited to 'sys-cluster/legion/legion-18.02.0.ebuild')
-rw-r--r--sys-cluster/legion/legion-18.02.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/sys-cluster/legion/legion-18.02.0.ebuild b/sys-cluster/legion/legion-18.02.0.ebuild
deleted file mode 100644
index 51357e884176..000000000000
--- a/sys-cluster/legion/legion-18.02.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A data-centric parallel programming system"
-HOMEPAGE="http://legion.stanford.edu/"
-if [[ $PV = 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="gasnet +hwloc test"
-
-DEPEND="
- gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
- "
-
-src_configure() {
- mycmakeargs=(
- -DLegion_USE_HWLOC=$(usex hwloc)
- -DLegion_USE_GASNet=$(usex gasnet)
- -DLegion_ENABLE_TESTING=$(usex test)
- -DBUILD_SHARED_LIBS=ON
- -DLegion_BUILD_EXAMPLES=ON
- -DLegion_BUILD_TESTS=ON
- -DLegion_BUILD_TUTORIAL=ON
- )
- cmake-utils_src_configure
-}