summaryrefslogtreecommitdiff
path: root/sys-cluster/kubeadm/kubeadm-1.23.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-15 21:34:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-15 21:34:37 +0000
commitda407288bb9fc771488c3fee13fc2f8561681e66 (patch)
treef424c3ecbe17ec2f2e75f726f6337bed848b2ccf /sys-cluster/kubeadm/kubeadm-1.23.13.ebuild
parentdc0ab0fa29dee64ee586cc23ddd306c0ad9ae7dc (diff)
gentoo auto-resync : 15:12:2022 - 21:34:37
Diffstat (limited to 'sys-cluster/kubeadm/kubeadm-1.23.13.ebuild')
-rw-r--r--sys-cluster/kubeadm/kubeadm-1.23.13.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/sys-cluster/kubeadm/kubeadm-1.23.13.ebuild b/sys-cluster/kubeadm/kubeadm-1.23.13.ebuild
deleted file mode 100644
index 0789de0b701a..000000000000
--- a/sys-cluster/kubeadm/kubeadm-1.23.13.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
-HOMEPAGE="https://kubernetes.io"
-SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64"
-IUSE="hardened"
-
-BDEPEND=">=dev-lang/go-1.17"
-
-RESTRICT+=" test"
-S="${WORKDIR}/kubernetes-${PV}"
-
-src_compile() {
- CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
- emake -j1 GOFLAGS=-v GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
-}
-
-src_install() {
- dobin _output/bin/${PN}
- _output/bin/${PN} completion bash > ${PN}.bash || die
- _output/bin/${PN} completion zsh > ${PN}.zsh || die
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-}