summaryrefslogtreecommitdiff
path: root/sys-cluster/kubeadm/kubeadm-1.15.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /sys-cluster/kubeadm/kubeadm-1.15.4.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'sys-cluster/kubeadm/kubeadm-1.15.4.ebuild')
-rw-r--r--sys-cluster/kubeadm/kubeadm-1.15.4.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/sys-cluster/kubeadm/kubeadm-1.15.4.ebuild b/sys-cluster/kubeadm/kubeadm-1.15.4.ebuild
deleted file mode 100644
index ffd3646b62e1..000000000000
--- a/sys-cluster/kubeadm/kubeadm-1.15.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot bash-completion-r1
-
-EGO_PN="k8s.io/kubernetes"
-ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
-HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
-SRC_URI="${ARCHIVE_URI}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=dev-lang/go-1.12
- dev-go/go-bindata"
-
-RESTRICT="test"
-
-src_prepare() {
- default
- sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
- sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
-}
-
-src_compile() {
- LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
- pushd src/${EGO_PN} || die
- _output/bin/${PN} completion bash > ${PN}.bash || die
- _output/bin/${PN} completion zsh > ${PN}.zsh || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin _output/bin/${PN}
-
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-
- popd || die
-}