summaryrefslogtreecommitdiff
path: root/sys-cluster/kube-proxy/kube-proxy-1.29.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-20 02:08:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-20 02:08:45 +0000
commitaec90632962b8bc48f23a1b5505d8afa0dfb6943 (patch)
tree7f137c721802f50a96c865424e51d1fb73d1baf4 /sys-cluster/kube-proxy/kube-proxy-1.29.1.ebuild
parent2b2f431a0021b4787ca3c028cefb30ad81347778 (diff)
gentoo auto-resync : 20:01:2024 - 02:08:45
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.29.1.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.29.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.29.1.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.29.1.ebuild
new file mode 100644
index 000000000000..a88d05e60e65
--- /dev/null
+++ b/sys-cluster/kube-proxy/kube-proxy-1.29.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Kubernetes Proxy service"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hardened"
+
+RDEPEND="net-firewall/conntrack-tools"
+BDEPEND=">=dev-lang/go-1.20"
+
+RESTRICT+=" test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" FORCE_HOST_GO=yes \
+ WHAT=cmd/${PN}
+}
+
+src_install() {
+ dobin _output/bin/${PN}
+ keepdir /var/log/${PN} /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+}