summaryrefslogtreecommitdiff
path: root/sys-cluster/kube-proxy/kube-proxy-1.24.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 22:58:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 22:58:46 +0100
commitd458376753e8fa261bdf469a99543577fb8d95a0 (patch)
tree992cbc8e12d59798356ceec140b070eca030173e /sys-cluster/kube-proxy/kube-proxy-1.24.15.ebuild
parent3be8faef74cb863e207124a6fccbf01ce90c0799 (diff)
gentoo auto-resync : 15:09:2023 - 22:58:46
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.24.15.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.24.15.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.24.15.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.24.15.ebuild
deleted file mode 100644
index d228a4990b81..000000000000
--- a/sys-cluster/kube-proxy/kube-proxy-1.24.15.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module
-
-DESCRIPTION="Kubernetes Proxy service"
-HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
-SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64"
-IUSE="hardened"
-
-RDEPEND="net-firewall/conntrack-tools"
-BDEPEND=">=dev-lang/go-1.18.1"
-
-RESTRICT+=" test"
-S="${WORKDIR}/kubernetes-${PV}"
-
-src_compile() {
- CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
- emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
-}
-
-src_install() {
- dobin _output/bin/${PN}
- keepdir /var/log/${PN} /var/lib/${PN}
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotated ${PN}
-}