summaryrefslogtreecommitdiff
path: root/sys-cluster/kube-proxy/kube-proxy-1.21.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /sys-cluster/kube-proxy/kube-proxy-1.21.3.ebuild
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.21.3.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.21.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.21.3.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.21.3.ebuild
new file mode 100644
index 000000000000..6c8c309ffd31
--- /dev/null
+++ b/sys-cluster/kube-proxy/kube-proxy-1.21.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="Kubernetes Proxy service"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hardened"
+
+RDEPEND="net-firewall/conntrack-tools
+ !sys-cluster/kubernetes"
+BDEPEND=">=dev-lang/go-1.16"
+
+RESTRICT+=" test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
+}
+
+src_install() {
+ dobin _output/bin/${PN}
+ keepdir /var/log/${PN} /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+}