summaryrefslogtreecommitdiff
path: root/sys-cluster/kube-controller-manager/kube-controller-manager-1.22.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /sys-cluster/kube-controller-manager/kube-controller-manager-1.22.6.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'sys-cluster/kube-controller-manager/kube-controller-manager-1.22.6.ebuild')
-rw-r--r--sys-cluster/kube-controller-manager/kube-controller-manager-1.22.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-cluster/kube-controller-manager/kube-controller-manager-1.22.6.ebuild b/sys-cluster/kube-controller-manager/kube-controller-manager-1.22.6.ebuild
new file mode 100644
index 000000000000..3611bae7ae46
--- /dev/null
+++ b/sys-cluster/kube-controller-manager/kube-controller-manager-1.22.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="Kubernetes Controller Manager"
+HOMEPAGE="https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hardened"
+
+COMMON_DEPEND="acct-group/kube-controller-manager
+ acct-user/kube-controller-manager"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ !sys-cluster/kubernetes"
+BDEPEND=">=dev-lang/go-1.16"
+
+RESTRICT+=" test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake -j1 GOFLAGS=-v GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
+}
+
+src_install() {
+ dobin _output/bin/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}