summaryrefslogtreecommitdiff
path: root/sys-cluster/hpx/hpx-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /sys-cluster/hpx/hpx-9999.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'sys-cluster/hpx/hpx-9999.ebuild')
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild63
1 files changed, 30 insertions, 33 deletions
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index 9f8589d79686..a57d12d298d1 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -1,70 +1,67 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-if [ ${PV} == 9999 ] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
else
- SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
+ SRC_URI="https://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}_${PV}"
fi
-
-inherit cmake-utils fortran-2 multilib python-any-r1
+inherit cmake-utils fortran-2 python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
-HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
+HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
IUSE="doc examples jemalloc papi +perftools tbb test"
+REQUIRED_USE="?? ( jemalloc perftools tbb )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( >=dev-libs/boost-1.56.0-r1[tools] )
+"
RDEPEND="
- tbb? ( dev-cpp/tbb )
- >=dev-libs/boost-1.49
- papi? ( dev-libs/papi )
- perftools? ( >=dev-util/google-perftools-1.7.1 )
+ >=dev-libs/boost-1.49:=
>=sys-apps/hwloc-1.8
>=sys-libs/libunwind-1
sys-libs/zlib
+ papi? ( dev-libs/papi )
+ perftools? ( >=dev-util/google-perftools-1.7.1 )
+ tbb? ( dev-cpp/tbb )
"
DEPEND="${RDEPEND}
- virtual/pkgconfig
test? ( ${PYTHON_DEPS} )
- doc? ( >=dev-libs/boost-1.56.0-r1:=[tools] )
"
-REQUIRED_USE="
- jemalloc? ( !perftools !tbb )
- perftools? ( !jemalloc !tbb )
- tbb? ( !jemalloc !perftools )
- "
pkg_setup() {
use test && python-any-r1_pkg_setup
}
src_configure() {
- CMAKE_BUILD_TYPE=Release
local mycmakeargs=(
- -DHPX_BUILD_EXAMPLES=OFF
- -DHPX_MALLOC=system
- -DLIB=$(get_libdir)
- -Dcmake_dir=cmake
- -DHPX_BUILD_DOCUMENTATION=$(usex doc)
- -DHPX_JEMALLOC=$(usex jemalloc)
+ -DHPX_WITH_EXAMPLES=OFF
+ -DHPX_WITH_DOCUMENTATION=$(usex doc)
+ -DHPX_WITH_PAPI=$(usex papi)
+ -DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
-DBUILD_TESTING=$(usex test)
- -DHPX_GOOGLE_PERFTOOLS=$(usex perftools)
- -DHPX_PAPI=$(usex papi)
)
-
- use perftools && mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
- use jemalloc && mycmakeargs+=( -DHPX_MALLOC=jemalloc )
- use tbb && mycmakeargs+=( -DHPX_MALLOC=tbbmalloc )
+ if use jemalloc; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=jemalloc )
+ elif use perftools; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tcmalloc )
+ elif use tbb; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tbbmalloc )
+ else
+ mycmakeargs+=( -DHPX_WITH_MALLOC=system )
+ fi
cmake-utils_src_configure
}
@@ -76,8 +73,8 @@ src_test() {
src_install() {
cmake-utils_src_install
- mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin"
if use examples; then
+ mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
insinto /usr/share/doc/${PF}
doins -r examples
fi