summaryrefslogtreecommitdiff
path: root/sys-cluster/hpx/hpx-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /sys-cluster/hpx/hpx-9999.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'sys-cluster/hpx/hpx-9999.ebuild')
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild31
1 files changed, 9 insertions, 22 deletions
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index 93a9bd8f1bd3..7f80474d33a5 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
@@ -19,8 +19,9 @@ HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
-IUSE="doc examples jemalloc mpi papi +perftools tbb test"
-RESTRICT="!test? ( test )"
+IUSE="examples jemalloc mpi papi +perftools tbb"
+# tests fail to compile
+RESTRICT="test"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -29,22 +30,14 @@ REQUIRED_USE="
BDEPEND="
virtual/pkgconfig
- doc? (
- ${PYTHON_DEPS}
- app-doc/doxygen
- $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_MULTI_USEDEP}]
- >=dev-python/breathe-4.22[${PYTHON_MULTI_USEDEP}]
- ')
- )
- test? ( ${PYTHON_DEPS} )
"
RDEPEND="
${PYTHON_DEPS}
+ dev-cpp/asio
dev-libs/boost:=
sys-apps/hwloc
sys-libs/zlib
+ jemalloc? ( dev-libs/jemalloc )
mpi? ( virtual/mpi )
papi? ( dev-libs/papi )
perftools? ( dev-util/google-perftools )
@@ -77,11 +70,11 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DHPX_WITH_EXAMPLES=OFF
- -DHPX_WITH_DOCUMENTATION=$(usex doc)
+ -DHPX_WITH_DOCUMENTATION=OFF
-DHPX_WITH_PARCELPORT_MPI=$(usex mpi)
-DHPX_WITH_PAPI=$(usex papi)
-DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
- -DBUILD_TESTING=$(usex test)
+ -DBUILD_TESTING=OFF
)
if use jemalloc; then
mycmakeargs+=( -DHPX_WITH_MALLOC=jemalloc )
@@ -98,12 +91,6 @@ src_configure() {
src_compile() {
cmake_src_compile
- use test && cmake_build tests
-}
-
-src_test() {
- # avoid over-suscribing
- cmake_src_test -j1
}
src_install() {