summaryrefslogtreecommitdiff
path: root/sys-cluster/glusterfs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-31 16:45:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-31 16:45:16 +0100
commitd12ee3457fd1a8bf18ede06882314fc1df30bd4b (patch)
tree33d42f682bfdfdf5fc26dd6bdd779853b8441ca0 /sys-cluster/glusterfs
parent53aea9d709c9286028405b25584181507f47442f (diff)
gentoo auto-resync : 31:07:2023 - 16:45:16
Diffstat (limited to 'sys-cluster/glusterfs')
-rw-r--r--sys-cluster/glusterfs/Manifest2
-rw-r--r--sys-cluster/glusterfs/glusterfs-11.0.ebuild211
2 files changed, 213 insertions, 0 deletions
diff --git a/sys-cluster/glusterfs/Manifest b/sys-cluster/glusterfs/Manifest
index a0cfce428719..5696e1205ced 100644
--- a/sys-cluster/glusterfs/Manifest
+++ b/sys-cluster/glusterfs/Manifest
@@ -6,6 +6,8 @@ AUX glusterfs.vim 139 BLAKE2B 73fdcb49c0c252784718b461541d5483e118bf1b83f445a6ce
AUX glusterfsd-10.2.initd 3042 BLAKE2B 27b79e854164bc2e75a69936abad90f774c1372089bd3d6fc44feef6a6566be39ec6dfe76f26c479a8466b3f76995616aea59c38b092343484dabe20572df45e SHA512 101db0f73dee54703cfb7d196eb6e22f11e15a48f6a18507391caf6b129041f74740757d2cb22492229d5be962126b587c3fb69d688820120f3c0f3be9c58f44
DIST glusterfs-10.2.tar.gz 8278598 BLAKE2B 48e70a244e34cc41a5befbe94635e945c95b87f26e5e1892b099d23a13c6fb70eefb2a66b247a564b03eeb0707ee480b50096b154b3ac5d2a13051e6371995b3 SHA512 290c701fbd3f100096ef26b589ee0714449fc620c35e62bcb5fe2fe8de5f64963b40d7d5fe1b97b274ba791fa45f4175305b6a112f184f6ce11a1e0dc9f7ea30
DIST glusterfs-10.4.tar.gz 8293872 BLAKE2B 01f8764cc71b7bac2ee0419f3f1069ac1c85e26314828b47f348b9bf88ad0b8aa327be16ccfe9cf820aebb7dd9477a7840c721df4435c895be91fed0b1129b7c SHA512 06c563ab77a29145b1fac44f5a56a91539accb69ba736fe6297aa3f38b128e68ba4f7d0b49ac6eb56397a51950fb4de882ff60037e91c61ad13dd89a18139d82
+DIST glusterfs-11.0.tar.gz 8355706 BLAKE2B d0ee895b8ce5f506d9bc1f8b962a0f29b0379f086bf18cff0092938b7c2f7025afa2fccf54f58ac751a184a3b0e91a086df2d6496892f204373e070d7576a5d6 SHA512 075f0025a1892ebb28d45d0a4e8971656319582dd7bc2c8b19ea26cd08a789bb54f8bc9752839706cd0ee0ca54be74245230bc453a5d1e9e163af84f08937e69
EBUILD glusterfs-10.2-r2.ebuild 5785 BLAKE2B ccea7cc47d33c2698836c327dfefd8b1ae6913369d33c060cb4a12960345c84ebc4341eb64b1cc17e8edf3b06c250350477fdc44c0c21b1c30529145bcedad62 SHA512 2bce6a9423bd21916afc524c18f17b1e24c13ce4d6726d30ea9eda377a329a262b5548211277962d16dc786741321d779a9f3d6cce9dae1f1c8309c17810d6e3
EBUILD glusterfs-10.4.ebuild 5799 BLAKE2B 57288a885b112b004d9f1e5e97d4a727e11936f0946037790cfb03a91dfed03db7583ccee9eb1baa65429a79fbde27530fb1dad6f8d87dde6e62b1f08eaa6402 SHA512 3ac7c9d8f212c995e19d84afd86f946d2dccf76781e4a61a81e3271efa62e87fd42f23d18f9db04875cd1c8792e1c8418671020388974d10383b6ab82a73da0c
+EBUILD glusterfs-11.0.ebuild 6003 BLAKE2B 7513ad56e5b4f92879f849d694ec63004c756a69a12d7f383e92bad3a8ecd75d8460e50f6635e6887f8fcc1cc53c71c44dec37b204678bccaa4dd7496a3d4ab7 SHA512 1cfb50c3f99ce906fcedc8e4d0ec1e1792bd821dd170c936eb2f01fcd2c8381c4d2ef74dcf6652971f596524978d5be2017c2e9478472bcec1f1a666d03e6d36
MISC metadata.xml 1575 BLAKE2B 8d83c4db883ecd85230029532fdd5cea2e51391c2659a5280d4eeb453390b8413c58aca550f365049de36914da4d0d977356ba30c29afe0ca8e58ff41d34d321 SHA512 07bd2f41605ab4f1bde167d8b3d620492c5d85ef77ea49ae53970ab579afcd70e1aae9a40e8856d88034045c7201fcccdb079efc0af0ac76f32fde3417d7ad76
diff --git a/sys-cluster/glusterfs/glusterfs-11.0.ebuild b/sys-cluster/glusterfs/glusterfs-11.0.ebuild
new file mode 100644
index 000000000000..d20ce8ba2b97
--- /dev/null
+++ b/sys-cluster/glusterfs/glusterfs-11.0.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools elisp-common python-single-r1 tmpfiles systemd bash-completion-r1
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="https://www.gluster.org/ https://github.com/gluster/glusterfs/"
+SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut 1)/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-3+ )"
+SLOT="0/${PV%%.*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="debug emacs +fuse georeplication ipv6 +libtirpc rsyslog selinux static-libs tcmalloc test +uring xml"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ georeplication? ( xml )
+ ipv6? ( libtirpc )"
+
+# the tests must be run as root
+RESTRICT="test"
+
+# sys-apps/util-linux is required for libuuid
+RDEPEND="
+ acct-group/gluster
+ acct-user/gluster
+ dev-libs/libaio
+ dev-libs/openssl:=[-bindist(-)]
+ net-libs/rpcsvc-proto
+ dev-libs/userspace-rcu:=
+ sys-apps/util-linux
+ sys-libs/readline:=
+ ${PYTHON_DEPS}
+
+ !elibc_glibc? ( sys-libs/argp-standalone )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ fuse? ( >=sys-fs/fuse-2.7.0:0 )
+ libtirpc? ( net-libs/libtirpc:= )
+ !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
+ selinux? ( sec-policy/selinux-glusterfs )
+ tcmalloc? ( dev-util/google-perftools )
+ uring? ( sys-libs/liburing:= )
+ xml? ( dev-libs/libxml2 )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/acl
+ test? (
+ >=dev-util/cmocka-1.0.1
+ app-benchmarks/dbench
+ dev-libs/xxhash
+ dev-vcs/git
+ virtual/perl-Test-Harness
+ dev-libs/yajl
+ sys-fs/xfsprogs
+ sys-apps/attr
+ )
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
+
+# Maintainer notes:
+# * The build system will always configure & build argp-standalone but it'll never use it
+# if the argp.h header is found in the system. Which should be the case with
+# glibc or if argp-standalone is installed.
+
+pkg_setup() {
+ python_setup "python3*"
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # build rpc-transport and xlators only once as shared libs
+ find rpc/rpc-transport xlators -name Makefile.am -exec \
+ sed -i 's|.*$(top_srcdir).*\.sym|\0 -shared|' {} + || die
+
+ # fix execution permissions
+ chmod +x libglusterfs/src/gen-defaults.py || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ YACC=yacc.bison \
+ LEX=flex \
+ --disable-fusermount \
+ --disable-lto \
+ $(use_enable debug) \
+ $(use_enable fuse fuse-client) \
+ $(use_enable georeplication) \
+ $(use_enable static-libs static) \
+ $(use_enable test cmocka) \
+ $(use_enable uring linux-io-uring) \
+ $(use_enable xml xml-output) \
+ $(usex ipv6 --with-ipv6-default "") \
+ $(usex libtirpc "" --without-libtirpc) \
+ $(usex tcmalloc "" --without-tcmalloc) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile extras/glusterfs-mode.el
+}
+
+src_test() {
+ ./run-tests.sh || die
+}
+
+src_install() {
+ default
+
+ # Path changes based on whether app-shells/bash-completion is installed, bug #911523
+ rm -rf "${ED}"/etc/bash_completion.d || die
+ newbashcomp extras/command-completion/gluster.bash ${PN}
+
+ rm \
+ "${ED}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
+ "${ED}"/etc/glusterfs/gluster-rsyslog-*.conf \
+ "${ED}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/glusterfs.logrotate glusterfs
+
+ if use rsyslog ; then
+ insinto /etc/rsyslog.d
+ newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
+ fi
+
+ if use emacs ; then
+ elisp-install ${PN} extras/glusterfs-mode.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
+
+ # insert some other tools which might be useful
+ insinto /usr/share/glusterfs/scripts
+ doins \
+ extras/backend-{cleanup,xattr-sanitize}.sh \
+ extras/clear_xattrs.sh \
+ extras/migrate-unify-to-distribute.sh
+
+ # correct permissions on installed scripts
+ # fperms 0755 /usr/share/glusterfs/scripts/*.sh
+ chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
+
+ newinitd "${FILESDIR}/glusterfsd-10.2.initd" glusterfsd
+ newinitd "${FILESDIR}/glusterd-10.2-r2.initd" glusterd
+ newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+ keepdir /var/log/${PN}
+ keepdir /var/lib/glusterd/{events,glusterfind/.keys}
+
+ systemd_dounit extras/systemd/{glusterd,glustereventsd,glusterfssharedstorage,gluster-ta-volume}.service
+
+ # QA
+ rm -r "${ED}/var/run/" || die
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.la' -delete || die
+ fi
+
+ python_optimize "${ED}"
+}
+
+pkg_postinst() {
+ tmpfiles_process gluster.conf
+
+ elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+ elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+ elog " /etc/init.d/glusterd start"
+ echo
+ elog "For static configurations, the glusterfsd startup script can be multiplexed."
+ elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+ elog "separate service. To create additional instances of the glusterfsd service"
+ elog "simply create a symlink to the glusterfsd startup script."
+ echo
+ elog "Example:"
+ elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
+ elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+ elog "You can now treat glusterfsd2 like any other service"
+ echo
+ ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+ ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+ ewarn "run GlusterFS."
+ echo
+ elog "If you are upgrading from a previous version of ${PN}, please read:"
+ elog " http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(ver_cut '1-2')/"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}