summaryrefslogtreecommitdiff
path: root/sys-cluster/crmsh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sys-cluster/crmsh
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sys-cluster/crmsh')
-rw-r--r--sys-cluster/crmsh/Manifest1
-rw-r--r--sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/Manifest b/sys-cluster/crmsh/Manifest
index 007025567ed6..b9a8762b0f7e 100644
--- a/sys-cluster/crmsh/Manifest
+++ b/sys-cluster/crmsh/Manifest
@@ -1,3 +1,4 @@
DIST crmsh-4.2.1.tar.gz 1058921 BLAKE2B 84d1f8685e792d9f453b2d185ccda4e8c2c9566becd85ed8308c014bd18e1479f601f3e89e4a1c3464c0d5bb797d7ddf9ddff479cd8c4c0d2998fd528f8ecbd2 SHA512 df0945f1b977993a0aca89af7c9030bc798aac4397a9d448d47bf68331e8aec83fa6155f2897f3c84573bcdb20fa384a1489b4f1d69fd1a831ece2fdb2b5b321
EBUILD crmsh-4.2.1-r1.ebuild 915 BLAKE2B 491f31b3add8b294a447c8ef3c883f965f2b8a5d3ee1acf843a6f56d82695cc762c3d4181ebf52d277c388c43fcda9191aeacca22285a9da6361a1d5d706a735 SHA512 e420ce9d65ec0554fbbc59ea7facb5a6675e60fafb027fd144a07fb008775d01781c4c8a06133d47331408164f3d797cb435a76e99c31a9d809ebdd0d7e599cd
+EBUILD crmsh-4.2.1-r2.ebuild 878 BLAKE2B d9e4af1e084534f334e7cd730098c3ed187b469e5ade0598158d0baf49244760512c62146ade4aad15184fbca52398ea4f75ddb73ba6b1a066b83d415d76a173 SHA512 23a0945babed96f0a2123d65d23be03f4763b8eacbe067280758c888a5e2b5f036384878cffe6e4b20aaab5b1b5a3e270e0e43d1acea0f5b3b0d06286a5004e8
MISC metadata.xml 344 BLAKE2B 3dd1aba1bed81c9993d1d9527e5695c4538c32014dc4da3303c602031182421f50629296c69f2f821455d29a0beb01a94b86541421d31462d37b05bbd57b41f0 SHA512 8fddf2b64d5dbdc79ccc206e36e33c2aee2c17ffc1c6012c80431d3d487734538c6efc3e3b6803407535783b1afa91901b929220874f8d20ce2616ad6cdb967d
diff --git a/sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild b/sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild
new file mode 100644
index 000000000000..ffab4f2a9c1d
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-3
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit autotools python-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/parallax[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_foreach_impl python_optimize
+}